Must disable and enable output sync to clear problem

Post Reply
Gaubie
Posts: 66
Joined: Mon Nov 06, 2006 4:48 pm
Location: New Jersey

Must disable and enable output sync to clear problem

Post by Gaubie » Wed Dec 01, 2010 4:47 am

I use Live to send sync via IAC. If closing Live without disabling output sync from the MIDI preference dialog; when launching a Live again, Live's MIDI tracks do not receive MIDI from the other IAC port even though the MIDI track IN indicator flashes in the upper left hand corner. (Note that the above mentioned actions does not reproduce that problem consistently).

As a matter of fact, ALL INS from the drop down menu won't even work for other ports receiving MIDI other than IAC. For example, a MIDI track normally receives messages from the COMPUTER MIDI KEYBOARD when ALL INS is selected from the drop down menu. But in this case it doesn't. I would actually need to choose COMPUTER KEYBOARD from the drop down menu.

I found that simply disabling sync and enable again resolves the issue.

Live 8.2.1 Demo
OSX 10.4.11 PPC
"It's more fun to compute". Yeah, when you know what you're doing!

Amaury
Posts: 5884
Joined: Mon Mar 20, 2006 6:59 pm
Location: Ableton Headquarters
Contact:

Re: Must disable and enable output sync to clear problem

Post by Amaury » Wed Dec 01, 2010 9:55 am

Gaubie wrote:I use Live to send sync via IAC. If closing Live without disabling output sync from the MIDI preference dialog; when launching a Live again, Live's MIDI tracks do not receive MIDI from the other IAC port even though the MIDI track IN indicator flashes in the upper left hand corner. (Note that the above mentioned actions does not reproduce that problem consistently).

As a matter of fact, ALL INS from the drop down menu won't even work for other ports receiving MIDI other than IAC. For example, a MIDI track normally receives messages from the COMPUTER MIDI KEYBOARD when ALL INS is selected from the drop down menu. But in this case it doesn't. I would actually need to choose COMPUTER KEYBOARD from the drop down menu.

I found that simply disabling sync and enable again resolves the issue.

Live 8.2.1 Demo
OSX 10.4.11 PPC
Hi,

Just to make sure: is the "Track" input also enabled for your IAC port?

Kind regards,
Amaury
Ableton Product Team

Gaubie
Posts: 66
Joined: Mon Nov 06, 2006 4:48 pm
Location: New Jersey

Re: Must disable and enable output sync to clear problem

Post by Gaubie » Thu Dec 02, 2010 4:03 am

Hi Amaury,
It is but on a different port. I forgot to post this snap shot of my configuration last night.
(Those things happen when ignore my alarm to take breaks :oops: )

http://dl.dropbox.com/u/15940221/MIDI%20Pref.jpg
"It's more fun to compute". Yeah, when you know what you're doing!

kleine
Posts: 1850
Joined: Sat Dec 15, 2001 11:46 am
Location: ableton
Contact:

Re: Must disable and enable output sync to clear problem

Post by kleine » Mon Dec 06, 2010 12:52 pm

Hello,

I can´t reproduce this problem using an IntelMac - i don´t have a PPC at the moment.
Could you try to create a new audio MIDI setup with apple´s Audio MIDI setup utility?

Let me know if this changes anything.

best,
Christian

Gaubie
Posts: 66
Joined: Mon Nov 06, 2006 4:48 pm
Location: New Jersey

Re: Must disable and enable output sync to clear problem

Post by Gaubie » Mon Dec 13, 2010 5:52 am

[Edit]
I discovered that restarting my computer actually resolves the problem for a while, not disabling and reactivating sync as originally stated in my post.
I should note that the problem occurs only with the IAC buss. Also, sync output from live is stable. Live just won't receive MIDI. Live's MIDI In indicator does indeed indicate it is receiving MIDI, but not the tracks.

I ran into two other mac users who experience the same.
"It's more fun to compute". Yeah, when you know what you're doing!

Post Reply