push 2 repair?

Come here to discuss Push with other users.
For tech support, please head to http://www.ableton.com/help
Post Reply
had-a-dat
Posts: 2
Joined: Fri Nov 20, 2020 10:11 am

push 2 repair?

Post by had-a-dat » Fri Nov 20, 2020 10:23 am

How do I find out if there is a Factory warranty for push 2? I have had it not even 4 months and it just keeps going blank and going back to the Ableton logo. I tried scouring internet for people who have have similar issues to trouble shoot mine i.e. checking the preferences to make sure there wasn't 2 push things in the midi tab, switching usb cables, ports, uninstalling Ableton and reinstalling... I've done just about everything I can think of. I didn't drop it or anything I dont understand why it just doesn't work. I saved up literally for almost a year to purchase it new for 800 bucks and I stupidly didn't get the extra coverage from guitar center when I bought it because I didn't have the money and im devastated... is there a factory warranty? I tried to look into the contact Ableton for a support issue but they are so backed up it won't even load to send a request anyways... I dont know who to call or what to do.


any suggestions?


if any Ableton employee sees this and would like to contact me my contact info is below

** Also, if anyone else had any suggestions feel free to shoot me an email or even a text.


Thanks,
Dean Van Dyke
p. 619-204-1209
e. deanvandyke@protonmail.com

[jur]
Site Admin
Posts: 2976
Joined: Mon Jun 01, 2015 3:04 pm
Location: Ableton

Re: push 2 repair?

Post by [jur] » Fri Nov 20, 2020 10:49 am

support@ableton.com
It's still taking longer than during the non-Covid days, sorry.
Ableton Forum Moderator

Psyguy
Posts: 1
Joined: Mon Mar 15, 2021 9:09 am

Re: push 2 repair?

Post by Psyguy » Mon Mar 15, 2021 9:15 am

Hi.
Try updating drivers for your audio interface. I had similar issues, pads unresponsive etc and use Focusrite Scarlett. Once latest drivers installed it was fine.

ableproducer
Posts: 1
Joined: Tue Jun 15, 2021 8:53 am

Re: push 2 repair?

Post by ableproducer » Tue Jun 15, 2021 8:54 am

having this exact same issue, push 2 wont show up in lives preferences but shows up in device manager, can get it to load past the logo screen, have troubleshooted everything and checked all cables/connections.
did you end up finding a fix for your problem?

Post Reply