User colors on your Push!!!

Come here to discuss Push with other users.
For tech support, please head to http://www.ableton.com/help
sowhoso
Posts: 834
Joined: Thu Dec 27, 2007 1:14 am

Re: User colors on your Push!!!

Post by sowhoso » Tue Jul 16, 2013 12:10 pm

Image

turbomartin
Posts: 90
Joined: Fri Nov 17, 2006 11:48 am

Re: User colors on your Push!!!

Post by turbomartin » Tue Jul 16, 2013 12:52 pm

Is there an up-to-date and foolproof guide available somewhere?

Or, if anyone could direct me a bit, that would be very much appreciated :)

sowhoso
Posts: 834
Joined: Thu Dec 27, 2007 1:14 am

Re: User colors on your Push!!!

Post by sowhoso » Tue Jul 16, 2013 2:31 pm

see the first post and following. pretty simple so no need for "idiot proof" guidance

just alter the section titled class Instrument to your liking. i've only chnged the first two so far, base and scale:

class Instrument:
NoteBase = Rgb.RED.shade(2)
NoteScale = Rgb.OCEAN.shade(2)
NoteForeign = Rgb.MAGENTA
NoteInvalid = Rgb.BLACK
NoteInactive = Rgb.BLACK
NoteOff = Rgb.BLACK
Feedback = Rgb.ORCHID
FeedbackRecord = Rgb.RED.shade(1)


on windows 7 the file goes here:
C:\ProgramData\Ableton\Live 9 Standard\Resources\MIDI Remote Scripts\Push

it's a bit different if you have another 9 version, like suite

lyovino
Posts: 509
Joined: Thu May 27, 2010 3:29 am

Re: User colors on your Push!!!

Post by lyovino » Tue Jul 16, 2013 2:51 pm

sowhoso wrote:see the first post and following. pretty simple so no need for "idiot proof" guidance

just alter the section titled class Instrument to your liking. i've only chnged the first two so far, base and scale:

class Instrument:
NoteBase = Rgb.RED.shade(2)
NoteScale = Rgb.OCEAN.shade(2)
NoteForeign = Rgb.MAGENTA
NoteInvalid = Rgb.BLACK
NoteInactive = Rgb.BLACK
NoteOff = Rgb.BLACK
Feedback = Rgb.ORCHID
FeedbackRecord = Rgb.RED.shade(1)
1- I see you have scale notes set to red, doesn't this get a little confusing when notes are being played back in red also?
2- Deleting this file will bring push back to its default color state, is this true?
3- Does this file have to be replaced every time we update live?

Thanks.
iMac, Intel Core i7, 2.8 GHz, 16GB
Yosemite, Live 9.xx Suite (64- bit)
Push, Apogee Ensemble

sowhoso
Posts: 834
Joined: Thu Dec 27, 2007 1:14 am

Re: User colors on your Push!!!

Post by sowhoso » Tue Jul 16, 2013 3:17 pm

lyovino wrote:1- I see you have scale notes set to red, doesn't this get a little confusing when notes are being played back in red also?
not sure what you mean exactly, but it's not confusing, so far
2- Deleting this file will bring push back to its default color state, is this true?
3- Does this file have to be replaced every time we update live?
haven't tried these to find out

drez
Posts: 497
Joined: Tue Oct 28, 2003 10:23 pm
Location: Dallas, TX

Re: User colors on your Push!!!

Post by drez » Tue Jul 16, 2013 3:32 pm

sowhoso wrote:
lyovino wrote:1- I see you have scale notes set to red, doesn't this get a little confusing when notes are being played back in red also?
not sure what you mean exactly, but it's not confusing, so far
I think what he's getting at, if I may interject, is that normally when you are playing while NOT recording, the pad's show up as green when played. When you are recording, the pad's show up as red so you have a visual representation that you are in "recording mode".

If you change the normal state of the pad to red, what happens to those pad's when you are in recording mode?
http://www.twitter.com/dreznicek
http://www.soundcloud.com/dreznicek
MacBook Pro Retina Laptop, 2.7Ghz i7, 16Gig RAM, 500G SSD, Live 9, Push, Novation SL25 Mk2, iPad (TouchOSC, Lemur, Touch-Able), Reason

lyovino
Posts: 509
Joined: Thu May 27, 2010 3:29 am

Re: User colors on your Push!!!

Post by lyovino » Tue Jul 16, 2013 3:50 pm

sowhoso wrote:
lyovino wrote:1- I see you have scale notes set to red, doesn't this get a little confusing when notes are being played back in red also?
not sure what you mean exactly, but it's not confusing, so far
If you record a few notes they play back Green. Now if you Overdub they play back Red. I would think this would be a little confusing visually when inputting notes? (Red)
Last edited by lyovino on Tue Jul 16, 2013 4:03 pm, edited 1 time in total.
iMac, Intel Core i7, 2.8 GHz, 16GB
Yosemite, Live 9.xx Suite (64- bit)
Push, Apogee Ensemble

Because789
Posts: 440
Joined: Thu Apr 28, 2011 1:26 pm

Re: User colors on your Push!!!

Post by Because789 » Tue Jul 16, 2013 3:58 pm

lyovino wrote: 2- Deleting this file will bring push back to its default color state, is this true?
No, you have to roll back to the original SkinDefault.pyc. Be sure you to backup your Midi Remote Script folder if you change anything in there (even though there are other ways to get the original back).
lyovino wrote: 3- Does this file have to be replaced every time we update live?
The file will get replaced when you update Live (like now, as 9.0.5 ist officially out), at least if they made changes in the script. It might be that SkinDefault.py of 9.0.4 in Julians depository isn't compatible with 9.0.5 (haven't tried it).
Live 9.5 (64bit), Max 7.0.6, Windows 10, Push 2, Korg electribe2, Bass Station II, Launch Control XL, Faderfox DJ3

M4L

lyovino
Posts: 509
Joined: Thu May 27, 2010 3:29 am

Re: User colors on your Push!!!

Post by lyovino » Tue Jul 16, 2013 4:14 pm

Ableton should implement something along these lines in their software. This may be an easy way to alleviate the current pad color problems some are having.
Also, no need to worry about updating scripts that may have not been updated for the newest release of Live.
iMac, Intel Core i7, 2.8 GHz, 16GB
Yosemite, Live 9.xx Suite (64- bit)
Push, Apogee Ensemble

deva
Posts: 1685
Joined: Fri Jun 02, 2006 4:32 pm

Re: User colors on your Push!!!

Post by deva » Tue Jul 16, 2013 4:58 pm

sowhoso wrote:see the first post and following. pretty simple so no need for "idiot proof" guidance

just alter the section titled class Instrument to your liking. i've only chnged the first two so far, base and scale:

The first post was for an older version than 9.0.4... and now today is the new 9.0.5. WIll the method described in the first post work in 9.0.5? How do I undo it if it doesn't. I too would like an idiot proof guide that was up to date.

sowhoso
Posts: 834
Joined: Thu Dec 27, 2007 1:14 am

Re: User colors on your Push!!!

Post by sowhoso » Tue Jul 16, 2013 5:02 pm

drez wrote:
sowhoso wrote:
lyovino wrote:1- I see you have scale notes set to red, doesn't this get a little confusing when notes are being played back in red also?
not sure what you mean exactly, but it's not confusing, so far
I think what he's getting at, if I may interject, is that normally when you are playing while NOT recording, the pad's show up as green when played. When you are recording, the pad's show up as red so you have a visual representation that you are in "recording mode".

If you change the normal state of the pad to red, what happens to those pad's when you are in recording mode?
ok. that was mentioned in an earlier post and the record option cud not be found

use orange or whetever. orchid shade1 looks good, i like that even more against ocean shade2

:D

triant
Posts: 74
Joined: Wed Sep 09, 2009 6:05 pm

Re: User colors on your Push!!!

Post by triant » Tue Jul 16, 2013 6:10 pm

it looks like live 9.0.5 breaks the existing remote scripts, and if you're using a custom SkinDefaults.py file in your Push remote scripts folder, it will compile down and thus overwrite the new SkinDefaults.pyc file that comes with 9.0.5, rendering the Push unusable. at least it did with me - my push stopped working with ableton till i downloaded a fresh install, removed my custom SkinDefaults.py file from my old install, and replaced the .pyc file with the one from the fresh install. Push now works again, albeit with the default colors.

does anyone have a decompiled version of the 9.0.5 scripts yet? or know how to create them from the .pyc files? i got so used to my beautiful seapunk color-scheme that the default is just intolerably ugly now ;)

deva
Posts: 1685
Joined: Fri Jun 02, 2006 4:32 pm

Re: User colors on your Push!!!

Post by deva » Tue Jul 16, 2013 6:16 pm

triant wrote:it looks like live 9.0.5 breaks the existing remote scripts, and if you're using a custom SkinDefaults.py file in your Push remote scripts folder, it will compile down and thus overwrite the new SkinDefaults.pyc file that comes with 9.0.5, rendering the Push unusable. at least it did with me - my push stopped working with ableton till i downloaded a fresh install, removed my custom SkinDefaults.py file from my old install, and replaced the .pyc file with the one from the fresh install. Push now works again, albeit with the default colors.

does anyone have a decompiled version of the 9.0.5 scripts yet? or know how to create them from the .pyc files? i got so used to my beautiful seapunk color-scheme that the default is just intolerably ugly now ;)

Same here... 9.0.5 does not work with Push when I try to change colors as suggested. I also had to revert to a fresh copy of 9.0.5

Jbam4d
Posts: 3
Joined: Wed Jul 10, 2013 3:34 pm

Re: User colors on your Push!!!

Post by Jbam4d » Tue Jul 16, 2013 6:17 pm

True dat, it breaks 9.05 and you need the default SkinDefaults.pyc Push working again.

I'm also looking for the 9.05 uncompiled version of SkinDefaults

lyovino
Posts: 509
Joined: Thu May 27, 2010 3:29 am

Re: User colors on your Push!!!

Post by lyovino » Tue Jul 16, 2013 6:54 pm

Sorry, I cannot go down this road. With any hope, somewhere along the path Ableton will do what is needed.
Thanks.
iMac, Intel Core i7, 2.8 GHz, 16GB
Yosemite, Live 9.xx Suite (64- bit)
Push, Apogee Ensemble

Post Reply