SeaPush lost in Live 9.1.4

Come here to discuss Push with other users.
For tech support, please head to http://www.ableton.com/help
lyovino
Posts: 509
Joined: Thu May 27, 2010 3:29 am

SeaPush lost in Live 9.1.4

Post by lyovino » Mon Jul 28, 2014 12:34 am

Has anyone else lost SeaPush in 9.1.4? How can I get it back? I was using Strays PDE script, that's gone too..
(Great features.) I do updates and then loose some of the controls and aesthetics that I mostly enjoy. Go figure! From now on I will not do updates or just resort to the default rainbow and lack of features that should be a default on Push. Sorry for the rant.
iMac, Intel Core i7, 2.8 GHz, 16GB
Yosemite, Live 9.xx Suite (64- bit)
Push, Apogee Ensemble

Tarekith
Posts: 17431
Joined: Fri Jan 07, 2005 11:46 pm
Location: Ableton Forum Administrator
Contact:

Re: SeaPush lost in Live 9.1.4

Post by Tarekith » Mon Jul 28, 2014 1:56 am

Every update kills the scripts used for those, you have to wait until they are recompiled for the new version by someone.

Frustrating I know, SeaPush makes things soooooo much better looking.

lyovino
Posts: 509
Joined: Thu May 27, 2010 3:29 am

Re: SeaPush lost in Live 9.1.4

Post by lyovino » Mon Jul 28, 2014 2:11 am

Thanks for the reply Tarekith. Yes it's a complete bummer.. We should be happy about an update, but it hasn't been that way since Push and 3rd party scripts. Waiting...
iMac, Intel Core i7, 2.8 GHz, 16GB
Yosemite, Live 9.xx Suite (64- bit)
Push, Apogee Ensemble

Fossiel
Posts: 202
Joined: Thu Jul 25, 2013 10:56 am

Re: SeaPush lost in Live 9.1.4

Post by Fossiel » Mon Jul 28, 2014 11:42 am

Wouldnt it be extremely easy for Ableton to implement a coloring scheme option for the Push? Or am i thinking years ahead of time? :)

Tagor
Posts: 939
Joined: Thu Mar 12, 2009 3:18 am

Re: SeaPush lost in Live 9.1.4

Post by Tagor » Mon Jul 28, 2014 12:08 pm

more like lightyears

an editor for scales and some subfunctions would also be nice:
let us create in usermode a working clipmatrix + possibility
to map some encoders freely...

drez
Posts: 497
Joined: Tue Oct 28, 2003 10:23 pm
Location: Dallas, TX

Re: SeaPush lost in Live 9.1.4

Post by drez » Tue Jul 29, 2014 7:34 pm

Hey folks, sorry I haven't gotten this done. I'll try to decompile this tonight and post on my github.
http://www.twitter.com/dreznicek
http://www.soundcloud.com/dreznicek
MacBook Pro Retina Laptop, 2.7Ghz i7, 16Gig RAM, 500G SSD, Live 9, Push, Novation SL25 Mk2, iPad (TouchOSC, Lemur, Touch-Able), Reason

lyovino
Posts: 509
Joined: Thu May 27, 2010 3:29 am

Re: SeaPush lost in Live 9.1.4

Post by lyovino » Tue Jul 29, 2014 7:41 pm

drez,
Thank you very much for your efforts and very sorry you have to go through this with each update. It's too bad they could not incorporate this as a default choice. It would eliminate so much of their problems and ours… i.e. calibration tools etc.
iMac, Intel Core i7, 2.8 GHz, 16GB
Yosemite, Live 9.xx Suite (64- bit)
Push, Apogee Ensemble

yur2die4
Posts: 6453
Joined: Sat Oct 03, 2009 3:02 am
Location: Menasha, Wisconsin
Contact:

Re: SeaPush lost in Live 9.1.4

Post by yur2die4 » Tue Jul 29, 2014 11:49 pm


lyovino
Posts: 509
Joined: Thu May 27, 2010 3:29 am

Re: SeaPush lost in Live 9.1.4

Post by lyovino » Wed Jul 30, 2014 2:51 am

Thanks yur2die4!
iMac, Intel Core i7, 2.8 GHz, 16GB
Yosemite, Live 9.xx Suite (64- bit)
Push, Apogee Ensemble

yur2die4
Posts: 6453
Joined: Sat Oct 03, 2009 3:02 am
Location: Menasha, Wisconsin
Contact:

Re: SeaPush lost in Live 9.1.4

Post by yur2die4 » Wed Jul 30, 2014 3:30 am

Don't thank me, thank Stray. It is very cool of him to offer this free modification, and to update it!

lyovino
Posts: 509
Joined: Thu May 27, 2010 3:29 am

Re: SeaPush lost in Live 9.1.4

Post by lyovino » Wed Jul 30, 2014 3:55 am

Thanks for the link yur2die4..

Stray, if you are out there, I thank you very much and appreciate your efforts and loyalty.
iMac, Intel Core i7, 2.8 GHz, 16GB
Yosemite, Live 9.xx Suite (64- bit)
Push, Apogee Ensemble

Fossiel
Posts: 202
Joined: Thu Jul 25, 2013 10:56 am

Re: SeaPush lost in Live 9.1.4

Post by Fossiel » Wed Jul 30, 2014 7:36 am

Gents, thanks for your hard work!

drez
Posts: 497
Joined: Tue Oct 28, 2003 10:23 pm
Location: Dallas, TX

Re: SeaPush lost in Live 9.1.4

Post by drez » Wed Jul 30, 2014 4:47 pm

Well, it sounds like my decompile would be pointless with this availability. I don't have a problem providing the decompile on my Github instance, but stray's solution is better for folks to use.
http://www.twitter.com/dreznicek
http://www.soundcloud.com/dreznicek
MacBook Pro Retina Laptop, 2.7Ghz i7, 16Gig RAM, 500G SSD, Live 9, Push, Novation SL25 Mk2, iPad (TouchOSC, Lemur, Touch-Able), Reason

lyovino
Posts: 509
Joined: Thu May 27, 2010 3:29 am

Re: SeaPush lost in Live 9.1.4

Post by lyovino » Wed Jul 30, 2014 4:56 pm

drez,
Your SeaPush script and Strays PDE combined is a great package, my thanks to you and Stray.
iMac, Intel Core i7, 2.8 GHz, 16GB
Yosemite, Live 9.xx Suite (64- bit)
Push, Apogee Ensemble

yur2die4
Posts: 6453
Joined: Sat Oct 03, 2009 3:02 am
Location: Menasha, Wisconsin
Contact:

Re: SeaPush lost in Live 9.1.4

Post by yur2die4 » Wed Jul 30, 2014 6:49 pm

I like how instead of augmenting the Push files, the solution is to have a new Push directory and augment that.

This means that when you update Live, Push will retain it's functionality.

Post Reply