Push 2 crashes Live 9.5 EVERY TIME!

Come here to discuss Push with other users.
For tech support, please head to http://www.ableton.com/help
Biodiode
Posts: 3
Joined: Mon May 24, 2010 6:50 pm

Re: Push 2 crashes Live 9.5 EVERY TIME!

Post by Biodiode » Tue Nov 10, 2015 8:26 pm

Tried that and still crashes on the PC I use for music. Interestingly I booted Live with Push 2 off and, still with it off, selected the controller from the drop down in the midi input preference section. This crashed Live straight away, so maybe something iffy with the Push 2 driver?

zsklar
Posts: 33
Joined: Sat Jul 23, 2005 9:32 pm

Re: Push 2 crashes Live 9.5 EVERY TIME!

Post by zsklar » Wed Nov 11, 2015 6:43 am

I have done extensive testing and i am convinced there is an issue with the Push 2 Windows driver. I am not sure if there is something else conflicting with it as it creates a train wreck when I turn the Push 2 on with Live 9.5 .

Ableton has suggested I do a fresh install of Live on an external hard drive and see if the problem still exists. The last thing I am going to do is clean out my C drive just for the sake of getting Push 2 to work.

C'mon Ableton, it seems this is becoming a common issue with Windows users. Let's get the bug out so we can all enjoy the new Push!

lovelight
Posts: 238
Joined: Thu Oct 13, 2005 9:01 pm
Contact:

Re: Push 2 crashes Live 9.5 EVERY TIME!

Post by lovelight » Wed Nov 11, 2015 8:55 am

im wondering, why its necessary to do alot of changes to your computer, ive done everything, even bought a system cleaner with a heavy price tag, and then i stopped my self. Why? when everything works fine with live 9.2, how can it be your system / computer / drivers / vst, thats wrong, when it all works perfect before the upgrade ?

lyovino
Posts: 509
Joined: Thu May 27, 2010 3:29 am

Re: Push 2 crashes Live 9.5 EVERY TIME!

Post by lyovino » Wed Nov 11, 2015 2:31 pm

Personally I find 9.5 a great update but on my system it is nowhere near stable as in 9.2. In just over a week I have had more crashes then I did with the latter over the course of six months, and I'm using push 1. I have a feeling whatever your problem is, is probably software and hardware related. Good luck and please report back when you get your new push.
iMac, Intel Core i7, 2.8 GHz, 16GB
Yosemite, Live 9.xx Suite (64- bit)
Push, Apogee Ensemble

Buleriachk
Posts: 1257
Joined: Sat Dec 21, 2002 3:52 am
Location: Santa Barbara, CA
Contact:

Re: Push 2 crashes Live 9.5 EVERY TIME!

Post by Buleriachk » Wed Nov 11, 2015 2:50 pm

zsklar wrote:I have done extensive testing and i am convinced there is an issue with the Push 2 Windows driver. I am not sure if there is something else conflicting with it as it creates a train wreck when I turn the Push 2 on with Live 9.5.

Ableton has suggested I do a fresh install of Live on an external hard drive and see if the problem still exists. The last thing I am going to do is clean out my C drive just for the sake of getting Push 2 to work.

C'mon Ableton, it seems this is becoming a common issue with Windows users. Let's get the bug out so we can all enjoy the new Push!
I forgot to mention that I uninstalled Live at one point in the process, and then went through the registry with RegEdit and deleted every instance of "Live 9.5" that I found, rebooting several times during the process. (Uninstalling Live does NOT take remove your sets or "clean out your C drive"). I then went into "Program Data" and deleted Live 9.5 folder from there, and emptied the recycle bin. This eliminates any possibility that there is some kind of mis-addressing in the registry, and possible interactions from third party scripts. (Not logical, I know, but remember Sherlock Holmes.... :)

Then I reinstalled Live 9.5, still got the crash, installed the beta and the issue was solved. I'm running Win10 Pro, x64, so at least in my case it is not the windows drivers.

(Suggestion: after you have deleted everything 9.5 from your computer, don't reinstall it, just reinstall the beta 9.5.1b1 directly...)

Since then, I haven't had a single crash.

Biodiode
Posts: 3
Joined: Mon May 24, 2010 6:50 pm

Re: Push 2 crashes Live 9.5 EVERY TIME!

Post by Biodiode » Wed Nov 11, 2015 4:33 pm

I got an e-mail from Ableton support and after reviewing my crash log it appears that I have problem with rewire. They sent me a specific options file to use and I am now up and running and looking forward to a night with my new toy.

**edit**
Just had a follow up e-mail to confirm there is an issue if you have Presonus' Notion installed, which I do. They are aware of the problem and are working on it, which apparently may take weeks/months. Thankfully I don't use rewire much so will leave it disabled for now as I need PreSonus Notion for my choral/organ work.

uXs
Posts: 4
Joined: Fri Nov 20, 2015 9:05 pm

Re: Push 2 crashes Live 9.5 EVERY TIME!

Post by uXs » Fri Nov 20, 2015 9:14 pm

Any news on this?

Pretty sure I have the same problem: if Push is on when I start Live, it crashes, and if I start Push when Live is already running, Live crashes as well.

I have Notion too, and when I uninstall it the problem goes away and my Push + Live work just fine. I can't leave Notion uninstalled because I need it and I really don't want to do some uninstall/reinstall dance each time I want to use my Push. (If I even could, I don't know if Notion has some kind of maximum activation count maybe.)

(I mailed support with crash reports but I wanted to check/report here too, because well why not.)

Buleriachk
Posts: 1257
Joined: Sat Dec 21, 2002 3:52 am
Location: Santa Barbara, CA
Contact:

Re: Push 2 crashes Live 9.5 EVERY TIME!

Post by Buleriachk » Fri Nov 20, 2015 10:15 pm

My understanding is that even some of the 9.5 files came with the Python 2.7 framework "upgrade",so that may be what is crashing the program, especially if you are using vst's and controllers with Midi Remots Scripts.

In other words, The Bleeding Edge of Technology... even for 9.5...
roll back to an earlier version and see what happens...

uXs
Posts: 4
Joined: Fri Nov 20, 2015 9:05 pm

Re: Push 2 crashes Live 9.5 EVERY TIME!

Post by uXs » Sat Nov 21, 2015 9:22 pm

Earlier version? Pretty sure Push 2 requires 9.5.

Anybody know if the beta version solves it?

Buleriachk
Posts: 1257
Joined: Sat Dec 21, 2002 3:52 am
Location: Santa Barbara, CA
Contact:

Re: Push 2 crashes Live 9.5 EVERY TIME!

Post by Buleriachk » Sat Nov 21, 2015 9:49 pm

uXs wrote:Earlier version? Pretty sure Push 2 requires 9.5.

Anybody know if the beta version solves it?
For me, yes (Win 10 Pro, x64)
YMMV

uXs
Posts: 4
Joined: Fri Nov 20, 2015 9:05 pm

Re: Push 2 crashes Live 9.5 EVERY TIME!

Post by uXs » Sat Nov 21, 2015 10:58 pm

Yes... well that didn't quite work out. Not only does the beta version just crash on startup, the 'normal' 9.5 now crashes too (without starting Push), and it keeps crashing even after I removed the beta again.

Buleriachk
Posts: 1257
Joined: Sat Dec 21, 2002 3:52 am
Location: Santa Barbara, CA
Contact:

Re: Push 2 crashes Live 9.5 EVERY TIME!

Post by Buleriachk » Sun Nov 22, 2015 1:26 am

uXs wrote:Yes... well that didn't quite work out. Not only does the beta version just crash on startup, the 'normal' 9.5 now crashes too (without starting Push), and it keeps crashing even after I removed the beta again.
delete your default template file in the beta version?
and remove/uninstall all controllers to start?

uXs
Posts: 4
Joined: Fri Nov 20, 2015 9:05 pm

Re: Push 2 crashes Live 9.5 EVERY TIME!

Post by uXs » Sun Nov 22, 2015 1:41 am

Ok I got it to work now. Found some more Ableton files in AppData somewhere, deleted it all, and that seems to have fixed the problem I had with Live not starting at all.

Then I found this somewhere: https://www.ableton.com/en/help/article ... -file-live and created that file and disabled Rewire with it. And now Live + Push works :-) I'm curious if the non-beta version would work as well but not curious enough to find out.

jestermgee
Posts: 3383
Joined: Mon Apr 26, 2010 6:38 am
Contact:

Re: Push 2 crashes Live 9.5 EVERY TIME!

Post by jestermgee » Tue Nov 24, 2015 9:13 am

Well I had this issue also. Was using the release of 9.5 just fine with my setup and as soon as I got Push home and connected it Live would crash both during startup and even when Live was running and I switched on Push (Windows 7)

The Beta version seems to have fixed this issue for me and even after doing the firmware update in the beta, Push still crashes the 9.5 release.

lovelight
Posts: 238
Joined: Thu Oct 13, 2005 9:01 pm
Contact:

Re: Push 2 crashes Live 9.5 EVERY TIME!

Post by lovelight » Sat Nov 28, 2015 8:05 pm

Next week, after the update 9.5, it has been a month with crash, sky high cpu, unplayable songs made in live 9.2 because of the cpu mayhem. The great update 9.5, and the fantastic push 2 hasent been any pleasure yet, because of the mentioned problems above. Live 9.2 behaved nearly perfect, nearly no crashes, low cpu even in big projects.

i truly love Live and push 2, but for how long are we gonna wait, before we can work and enjoy the new live and the new Push normally again, with a working update that works like 9.2, in stability and workflow ?

best regards

Post Reply