serious Problem with several usb devices

Come here to discuss Push with other users.
For tech support, please head to http://www.ableton.com/help
frabo
Posts: 57
Joined: Fri Jan 11, 2008 1:24 pm

serious Problem with several usb devices

Post by frabo » Wed Nov 18, 2015 10:50 pm

Hi,
I have several usb devices, a frontier design Alphatrack, which works as a MackieControl in MCU mode, and a Microsoft 360 game controller, wich works with controller mate as a tool for navigation and for key commands !
With push1 I had no problems with this set up!
But now with push2! As far as I turned on push2, my 360 controller is not recognized by the system anymore! And the alpha track freezed and quit the working !
This happened even if I have these devices on an usb 3.0 hub, or if I plug only the push2 and one of these devices direct on the ports of my macbook pro !

—> System: MacBook Pro 15“ late 2013
2,6 GHz core i7
16 GB DD3
OS X 10.9.5
Live 9.5 and the beta 9.5.1.b2
If I plugged out the other device, osx crashed !!

jestermgee
Posts: 3458
Joined: Mon Apr 26, 2010 6:38 am
Contact:

Re: serious Problem with several usb devices

Post by jestermgee » Thu Nov 19, 2015 12:09 am

Have you tried powering Push from the AC adapter?

If you are just powering from USB then it may be draining power from the hum too much for other devices to work.

H20nly
Posts: 15838
Joined: Sat Oct 27, 2007 9:15 pm
Location: The Wild West

Re: serious Problem with several usb devices

Post by H20nly » Thu Nov 19, 2015 12:49 am

jestermgee wrote:If you are just powering from USB then it may be draining power from the hum too much for other devices to work.
agreed.

i believe Push 2 uses more power... probably due to the upgraded screen.

also, are you sure it's usb 3.0? often, not all the ports are... even on new systems (not sure on a 2013 Macbook). older versions of USB didn't step power up in the same way:

https://en.wikipedia.org/wiki/USB#USB_Power_Delivery

lovelight
Posts: 238
Joined: Thu Oct 13, 2005 9:01 pm
Contact:

Re: serious Problem with several usb devices

Post by lovelight » Thu Nov 19, 2015 6:59 am

maybe its a silly question, but is Push 2 usb port a 3.0 or 2.0 ?


http://lovelight.biz/

Tarekith
Posts: 17370
Joined: Fri Jan 07, 2005 11:46 pm
Location: Ableton Forum Administrator
Contact:

Re: serious Problem with several usb devices

Post by Tarekith » Thu Nov 19, 2015 7:48 am

2.0

frabo
Posts: 57
Joined: Fri Jan 11, 2008 1:24 pm

Re: serious Problem with several usb devices

Post by frabo » Thu Nov 19, 2015 8:14 am

- it is powered by the original AC adapter !
- it is a active, AC powered USB hub
the osx is 64 bit !

frabo
Posts: 57
Joined: Fri Jan 11, 2008 1:24 pm

Re: serious Problem with several usb devices

Post by frabo » Mon Nov 23, 2015 7:47 am

nobody with that kind of problems ?
... I can't believe it ...

:cry: :?

maara
Posts: 28
Joined: Tue Oct 04, 2011 7:57 am
Location: Prague

Re: serious Problem with several usb devices

Post by maara » Mon Nov 23, 2015 5:40 pm

frabo wrote:nobody with that kind of problems ?
... I can't believe it ...

:cry: :?
Not really - I am also having some weird usb behavior when the push 2 is connected to my win10 pc (on osx its fine). It seems like there is some thing what makes the usb subsystem to crash (my mouse stops working etc...) - I must restart the computer to fix that...
I was facing such issues few months ago when there was a problem with the drivers for my gaming joystick which was causing exactly the same kind of issues....
-----------------------------------------------------------
Live Suite 9+M4L+APC40+MOTU Ultralite MK3+Maschine MK2+AXIOM 25

telekom
Posts: 1128
Joined: Sun Apr 10, 2005 12:22 pm
Location: Glasgow, Scotland
Contact:

Re: serious Problem with several usb devices

Post by telekom » Sat Nov 28, 2015 1:40 pm

My crappy Maplin USB hub stopped working properly after I got Push 2. One of the USB ports no longer works - maybe it burnt out or something. I think the quality of the hub really matters. I have read on DJTechtools (I think) that this Anker hub is worth trying.

http://www.amazon.co.uk/Unibody-Aluminu ... ds=usb+hub
MacBook Pro Retina, Live 9.5, Reason, UC33, KRK RP5s, Teenage Engineering OP1, Korg ESX2, Korg Prophecy, Clavia Nord Lead, Bass, Guitars.
http://soundcloud.com/motorradkinophone

frabo
Posts: 57
Joined: Fri Jan 11, 2008 1:24 pm

Re: serious Problem with several usb devices

Post by frabo » Mon Nov 30, 2015 8:36 am

this has nothing to do with the hub
"This happened even if I have these devices on an usb 3.0 hub, or if I plug only the push2 and one of these devices direct on the ports of my macbook pro !"
It is really annoying, because like that I can't use the push2 - :cry:

fishmonkey
Posts: 4105
Joined: Wed Oct 24, 2007 4:50 am

Re: serious Problem with several usb devices

Post by fishmonkey » Tue Dec 01, 2015 6:11 am

i would try with another Mac. this will tell you if it is your machine that has issues or not...
badbrainz wrote: I'm a drummer, so I'm already at an intellectual disadvantage here

frabo
Posts: 57
Joined: Fri Jan 11, 2008 1:24 pm

Re: serious Problem with several usb devices

Post by frabo » Tue Dec 01, 2015 2:19 pm

No, it has nothing to do with the computer.
I plugged everything in, everything is working fine, turned on push2, everything is working fine,...
start live 9.5 or 9.5.1b3 (beta), after a while (just, when ableton connect to push2, and push2 lights up) the 360 controller is not listed in the system settings anymore. And there is no way to reactivate it.
After I plugged out the 360 or restart the computer, osx crashed !

please guys, everybody out there with a game controller or a usb midi controller and push2 - give a sign ...

:cry:

AdamJay
Posts: 4757
Joined: Thu Mar 11, 2004 7:17 pm
Location: Indianapolis, USA

Re: serious Problem with several usb devices

Post by AdamJay » Tue Dec 01, 2015 3:10 pm

I had some issues getting my Duet 2, Analog Rytm, Analog Four, and Push 2 to all live happily together.
In the end, it required an SMC reset of my Mac Pro plus keeping the Duet 2 and Push 2 on a seperate USB bus from the Elektrons.

Play with different USB configs and do an SMC reset.

fishmonkey
Posts: 4105
Joined: Wed Oct 24, 2007 4:50 am

Re: serious Problem with several usb devices

Post by fishmonkey » Tue Dec 01, 2015 10:55 pm

i have a lot of stuff connected with no drama. that unplugging the 360 controller causes a crash is suspicious. have you installed the latest version of Controllermate?

https://software.com/mac/apps/controllermate
badbrainz wrote: I'm a drummer, so I'm already at an intellectual disadvantage here

frabo
Posts: 57
Joined: Fri Jan 11, 2008 1:24 pm

Re: serious Problem with several usb devices

Post by frabo » Wed Dec 02, 2015 8:44 am

- I tried all possible USB configs, without a improvement

- yes, latest version of controllermate, but it has nothing to do with controllermate! It fails without opened controllermate.

And the 360 controller is one thing, the other is the Alphatrack in Mackie control mode.

Someone with a mackie or logic control and Push2 ?


:cry:

Post Reply