Anyone else find the Push 2 unplayable?

Come here to discuss Push with other users.
For tech support, please head to http://www.ableton.com/help
tedlogan
Posts: 1343
Joined: Thu Dec 20, 2012 7:23 pm
Location: Leamington Spa, UK
Contact:

Re: Anyone else find the Push 2 unplayable?

Post by tedlogan » Mon Nov 30, 2015 6:11 pm

Yes, i too have this problem on occasion, latest Beta. They did say at the time that it would not be fixed in the next beta though, which would have been the current one, b2.

In fact, it may not make the upcoming 9.5.1.

JPacker555
Posts: 17
Joined: Sun Nov 29, 2015 6:35 am

Re: Anyone else find the Push 2 unplayable?

Post by JPacker555 » Mon Nov 30, 2015 7:03 pm

emkays wrote:I'd recommend trying to find patterns in what causes it and contacting support. Hopefully that will help them solve it. The delay one is a little more unpredictable and I haven't yet found a repeatable pattern to the behaviour. It has something to do with legato playing as far as I can tell. But it doesn't happen often enough to be able to tell.
This part is the most problematic, as it is resulting in a lack of "feel". I agree that it is most likely something to do with legato playing, as its most noticeable when I try to do quicker riffs. The sensitivity overall is not great, as in addition to delayed notes, sometimes they just don't register all together, even with moderate pressure - this is with sensitivity at any value 0-10.

Just want to clarify that the key velocity bug is certainly an issue that needs to be fixed, but what I'm experiencing is separate (given that having the Accent button activated doesn't help). As emkays touched upon, currently my Push 2 could not be relied on for any type of synth recording or live performance, and thats a big reason why I bought it for.

I'm wondering, do you all think this is a firmware issue that could be fixed? Or is it part of the hardware, and I need to send this thing back while I still can?

ObtuseMoose
Posts: 137
Joined: Sat Dec 17, 2011 2:51 am

Re: Anyone else find the Push 2 unplayable?

Post by ObtuseMoose » Mon Nov 30, 2015 8:41 pm

JPacker555 wrote:I'm wondering, do you all think this is a firmware issue that could be fixed? Or is it part of the hardware, and I need to send this thing back while I still can?
I strongly suspect it's a firmware issue. Programming microcontrollers to read the state of buttons and encoders, update the LEDs and the display, send and receive data to and from the host, all with critical timing can be challenging. It's pretty easy to inadvertently introduce cases where you try reading something like pad pressure before the data is actually ready and end up getting a bogus value. It's easy for some unexpected combination or timing of events (like pad hits) to cause unexpected delays in processing.

Unless these types of errors can be made to show themselves relatively easily, they can be really hard to track down and fix. That's why finding a way to reproduce the problem or increase the likelihood that it will happen is so important.

I have no inside information (I don't work for Ableton), but I'm confident these issues can and will be fixed with a firmware update; it's just a matter of when. It's unfortunate that we have to live with it until then, but that's the way it is. Also, keep in mind that Push 2 comes with a 1 year warranty (in the US, might be different in other countries), so if it truly is a hardware defect, you have a year to get it repaired or replaced.

Just my opinions. YMMV
--
Moose
"all the musical ability of a blocked nostril"

emkays
Posts: 13
Joined: Fri Nov 13, 2015 11:51 pm

Re: Anyone else find the Push 2 unplayable?

Post by emkays » Mon Nov 30, 2015 8:53 pm

@jpacker555 I don't think there's an issue with your Push in particular. And I certainly hope there isn't with all of them. Certainly doubt it. I do however know they are at least aware of both issues and are working on an least the velocity issue. Hopefully these discusgsions push that up the priority list for them.

fishmonkey
Posts: 4093
Joined: Wed Oct 24, 2007 4:50 am

Re: Anyone else find the Push 2 unplayable?

Post by fishmonkey » Mon Nov 30, 2015 9:35 pm

tedlogan wrote:viewtopic.php?f=55&t=218344&start=15

In an older thread, a user reported that the devs have confirmed that there is a bug concerning unwanted loud velocities when playing very softly sometimes.
ah yeah, i forgot about that thread. one of my velocity issues definitely happens when i have a finger already lightly resting on a pad. pressing softly then sometimes causes an overly loud note...
badbrainz wrote: I'm a drummer, so I'm already at an intellectual disadvantage here

tedlogan
Posts: 1343
Joined: Thu Dec 20, 2012 7:23 pm
Location: Leamington Spa, UK
Contact:

Re: Anyone else find the Push 2 unplayable?

Post by tedlogan » Mon Nov 30, 2015 9:40 pm

fishmonkey wrote:
tedlogan wrote:viewtopic.php?f=55&t=218344&start=15

In an older thread, a user reported that the devs have confirmed that there is a bug concerning unwanted loud velocities when playing very softly sometimes.
ah yeah, i forgot about that thread. one of my velocity issues definitely happens when i have a finger already lightly resting on a pad. pressing softly then sometimes causes an overly loud note...
Yes, exactly the same here.

JPacker555
Posts: 17
Joined: Sun Nov 29, 2015 6:35 am

Re: Anyone else find the Push 2 unplayable?

Post by JPacker555 » Mon Nov 30, 2015 10:37 pm

emkays wrote:@jpacker555 I don't think there's an issue with your Push in particular. And I certainly hope there isn't with all of them. Certainly doubt it. I do however know they are at least aware of both issues and are working on an least the velocity issue. Hopefully these discusgsions push that up the priority list for them.
I guess if its not just mine, I am just confused then as to

a) why reviews were raving about the pads improved responsiveness
b) why they would release a model that was less playable than its predecessor

JPacker555
Posts: 17
Joined: Sun Nov 29, 2015 6:35 am

Re: Anyone else find the Push 2 unplayable?

Post by JPacker555 » Mon Nov 30, 2015 11:20 pm

emkays wrote:I'd recommend trying to find patterns in what causes it and contacting support. Hopefully that will help them solve it. The delay one is a little more unpredictable and I haven't yet found a repeatable pattern to the behaviour. It has something to do with legato playing as far as I can tell. But it doesn't happen often enough to be able to tell.
I think you are spot on that its legato playing, but also with less pad sensitivity in comparison to the Push 1. Here are two videos addressing both

https://www.youtube.com/watch?v=XsRUhDWlDAw
https://www.youtube.com/watch?v=xzIOaDP0JYI

emkays
Posts: 13
Joined: Fri Nov 13, 2015 11:51 pm

Re: Anyone else find the Push 2 unplayable?

Post by emkays » Thu Dec 03, 2015 2:07 am

So I think I've narrowed down what playing technique causes the delay to happen. I can pretty much make it happen everytime. It's actually the exact same technique that causes the velocity spikes. It's related to the "squeeze" response that I've talked about before and is kinda hard to explain. Unfortunately it's part of a very natural way of playing. Even if aware of it it's hard to avoid. Especially when playing legato. Essentially when gently approaching a pad, and "squeezing" it hard-ish, it triggers with varying amounts of delay (in addition to full velocities. Like I describe, this is not how instruments normally respond and feels pretty weird. Just thought I'd point out a way the it happens every time for me. Might not for you (though hopefully should in order to narrow down the behaviour).

[jur]
Site Admin
Posts: 1673
Joined: Mon Jun 01, 2015 3:04 pm
Location: Ableton

Re: Anyone else find the Push 2 unplayable?

Post by [jur] » Thu Dec 03, 2015 3:08 am

emkays wrote:So I think I've narrowed down what playing technique causes the delay to happen. I can pretty much make it happen everytime. It's actually the exact same technique that causes the velocity spikes. It's related to the "squeeze" response that I've talked about before and is kinda hard to explain. Unfortunately it's part of a very natural way of playing. Even if aware of it it's hard to avoid. Especially when playing legato. Essentially when gently approaching a pad, and "squeezing" it hard-ish, it triggers with varying amounts of delay (in addition to full velocities. Like I describe, this is not how instruments normally respond and feels pretty weird. Just thought I'd point out a way the it happens every time for me. Might not for you (though hopefully should in order to narrow down the behaviour).
Just to check: did you already sent this very helpful investigation of yours to the support?
If not, please do so. And in any case thanks a lot for your help and spending time narrowing it down.
As I understand it, the support answer mentioned earlier means that it won't be fixed for 9.5.1. Maybe, and hopefully, in 9.5.2.
Cheers,
Julien
Ableton Forum Moderator

emkays
Posts: 13
Joined: Fri Nov 13, 2015 11:51 pm

Re: Anyone else find the Push 2 unplayable?

Post by emkays » Thu Dec 03, 2015 3:25 am

Hi Julien. Yes, I have been reporting to support. They have been good at responding and confirming they've received my input. Just wanted to post here since others seemed to have had the same issues and I thought it might be reassuring to see these results. Looking forward to a fix from Ableton. Hoping these specific reports help them track down the issue faster.

JPacker555
Posts: 17
Joined: Sun Nov 29, 2015 6:35 am

Re: Anyone else find the Push 2 unplayable?

Post by JPacker555 » Thu Dec 03, 2015 3:43 am

emkays wrote:So I think I've narrowed down what playing technique causes the delay to happen. I can pretty much make it happen everytime. It's actually the exact same technique that causes the velocity spikes. It's related to the "squeeze" response that I've talked about before and is kinda hard to explain. Unfortunately it's part of a very natural way of playing. Even if aware of it it's hard to avoid. Especially when playing legato. Essentially when gently approaching a pad, and "squeezing" it hard-ish, it triggers with varying amounts of delay (in addition to full velocities. Like I describe, this is not how instruments normally respond and feels pretty weird. Just thought I'd point out a way the it happens every time for me. Might not for you (though hopefully should in order to narrow down the behaviour).
yes I agree that this is when I have the issue as well. When I play very fast, there is enough velocity that it doesn't matter. When I slow it down a bit for legato with more "feel", the gentle but firm press results in the delay (and velocity spikes). I do hope the delays are a manifestation of the velocity bug, I guess we'll see. Heres one more quick vid of some faster and slower playing to confirm

https://www.youtube.com/watch?v=kOh_t8jpNx8

I may be alone, but Ive found that a relatively high sensitivity on the Push1 (-15) is more responsive than the highest setting on Push 2 (10) (maybe part of same velocity bug), and I hope they can tweak the firmware to allow for a similar playstyle to its predecessor The following video has that about 17 seconds in

https://www.youtube.com/watch?v=XsRUhDWlDAw

Leave Trace
Posts: 11
Joined: Thu Nov 29, 2012 7:46 am

Re: Anyone else find the Push 2 unplayable?

Post by Leave Trace » Thu Dec 03, 2015 11:55 pm

I may be alone, but Ive found that a relatively high sensitivity on the Push1 (-15) is more responsive than the highest setting on Push 2 (10) (maybe part of same velocity bug), and I hope they can tweak the firmware to allow for a similar playstyle to its predecessor
-13 sensitivity was the expressive sweet spot for me on the Push 1. It's nice not having to deal with the occasional stuck/ghost notes, but I haven't been able to dial in the same delicate dynamics on the new one. I guess that's to be expected with the keypads have been completely redesigned and rebuilt, but it was a bummer realization to find this out, especially after all of the rave reviews about the new pads.

jobinho
Posts: 60
Joined: Fri Oct 25, 2013 5:18 pm

Re: Anyone else find the Push 2 unplayable?

Post by jobinho » Fri Dec 04, 2015 12:25 am

My Push 2 while being great fun is certainly lacking dynamic responce which is very disappointing.

The pressure I apply seems to play inconsistent velocities, like in the video above. Also, some pads fire at different velocities to one another.

I hope this is a software issue and not a huge oversight in the design + manufacture.

Jbvdb
Posts: 119
Joined: Tue Nov 17, 2015 1:38 pm

Re: Anyone else find the Push 2 unplayable?

Post by Jbvdb » Fri Dec 04, 2015 2:10 am

I was having variable velocity response issues with push the first but none whatsoever with push the second, I am guessing it is a defect in a few units only! Maybe something between the pads and the sensors like dust?

Post Reply