Page 1 of 12

Anyone else find the Push 2 unplayable?

Posted: Sun Nov 29, 2015 7:33 am
by JPacker555
I am comparing my Push1 and Push2 side by side, and the Push1 pads are significantly more sensitive and consistent. The Push 2 pads are sometimes unresponsive, or have a significant delay. Has anyone else had similar issues? I really wanted to like the Push 2, and am confused after reading such great reviews about its feel and playability. Wondering if perhaps I received a defective unit. Below are some videos detailing the problem (3rd shows it best with plain square wave)

1) https://youtu.be/nup_ILDpqF4
2) https://www.youtube.com/watch?v=XsRUhDWlDAw - some sensitivity comparisons halfway through
3) https://www.youtube.com/watch?v=kOh_t8jpNx8 - faster vs slower playing with square wave

Re: Anyone else find the Push 2 unplayable?

Posted: Sun Nov 29, 2015 8:09 am
by Tarekith
That does not at all sound normal unfortunately. Does it feel like that with only the Push 2 plugged in?

Re: Anyone else find the Push 2 unplayable?

Posted: Sun Nov 29, 2015 3:40 pm
by JPacker555
yea it happens when its just the Push 2 plugged in, also tried them both on a different computer ( 1-mid 2011 MacBook Air Core i5, late 2014 Core i5 mac mini) with the same results. Hoping its just defective

Re: Anyone else find the Push 2 unplayable?

Posted: Sun Nov 29, 2015 3:48 pm
by ObtuseMoose
JPacker555 wrote:...The Push 2 pads are sometimes unresponsive, or have a significant delay. Has anyone else had similar issues? ...
Yes, I've noticed these things and I'm trying to find ways to reproduce them so I can submit them to support. They happen very seldom in normal use.

1. Occasional full velocity notes with light taps on the pad. I think this may be related to the known issue of touching a pad lightly (too light to trigger a note) and increasing pressure until it eventually spits out a note at full velocity.

2. Occasional unresponsive pad during normal playing. I'm not the most consistent player, so I'm trying to figure out if it's just me not hitting the pad hard enough, or what. Still trying to find settings for pad gain, sensitivity, and dynamics to accomodate my style.

3. Occasional delay in a note sounding.

I speculate that these COULD conceivably all be manifestations of the same problem. Perhaps as I'm playing, I'm sometimes laying my finger on a pad and then increasing pressure instead of a sharp tap. As I said, I'm still trying to figure out if it's me or the Push.

I'm not TOO concerned about it yet; I'm hoping a firmware update will be released soon to address some of the more serious issues.

--
Moose

Re: Anyone else find the Push 2 unplayable?

Posted: Sun Nov 29, 2015 7:23 pm
by Buleriachk
This is, uh, kind of embarrassing, but when I first sat down to play with Push 2 (after a number of Windows 10 updates), I noticed the pads were REALLY unresponsive (huge latency, compared to Push 1), and I started playing with the User options, to no avail. It was driving me nuts.

Finally it dawned on me to check my audio, and I discovered that the changes and removed my ASIO, and was trying to play the audio from my sound card using MME/Direct. Duh!

Switched it back to ASIO, and everything was fine again....

(Hey, I'm getting older, and had a mind fart, ok? ... :)

Re: Anyone else find the Push 2 unplayable?

Posted: Sun Nov 29, 2015 8:02 pm
by tedlogan
Heh, yeah...just had mind flatulence too. Two drumracks weren't responding to very soft velocities at all.
After adjusting Push's Pad sensitivity with not much improvement I thought perhaps the pads are actually quite crap.

Turns out both kits had gates on them, totally muting everything below a certain threshold.

yeah...

Re: Anyone else find the Push 2 unplayable?

Posted: Sun Nov 29, 2015 8:04 pm
by JPacker555
Thank you for the replies -
Obtuse - perhaps mine is part of that problem, though I'm not sure as its happening when I try to play a bit faster

Buler - I'm not sure if that is the issue, since I have tried the Push 2 vs Push 1 at the same time and the issue is the same.

I have posted a video showing the comparison, linked in the original post

Re: Anyone else find the Push 2 unplayable?

Posted: Sun Nov 29, 2015 10:10 pm
by emkays
Yes. There is a significant playability issue with Push 2. I've seen both, the dynamic response and note delay. The latter is not as common though on my end (though still happens every day I use it). They did seem to improve sensitivity/cross-talk/false triggers compared to the Push 1. But overall playability really does not work for anything other that short percussive or triggered sounds. There are a couple other threads here about it. I think you responded to my post in one of them. It's something in the way it interprets velocity. I've written Ableton as extensively as I could understand the issue. There's some misinterpreted data generated from various combinations of: legato playing, aftertouch, and "squeeze" of a note. The latter is a bit strange to explain, but it consistently is what causes dynamic jumps. On most natural instruments loudness is determined in how quickly/hard you attack a note, but the Push seems to generate a louder value even when you approach it very gently and "squeeze" it harder when playing. This is very unnatural to say the least regardless of having experience with many real instruments and controllers, and makes it pretty impossible to play anything predictably. This really needs to get fixed.

I'd recommend trying to find patterns in what causes it and contacting support. Hopefully that will help them solve it. The delay one is a little more unpredictable and I haven't yet found a repeatable pattern to the behaviour. It has something to do with legato playing as far as I can tell. But it doesn't happen often enough to be able to tell.

Re: Anyone else find the Push 2 unplayable?

Posted: Sun Nov 29, 2015 11:43 pm
by fishmonkey
emkays wrote:It's something in the way it interprets velocity. I've written Ableton as extensively as I could understand the issue. There's some misinterpreted data generated from various combinations of: legato playing, aftertouch, and "squeeze" of a note. The latter is a bit strange to explain, but it consistently is what causes dynamic jumps. On most natural instruments loudness is determined in how quickly/hard you attack a note, but the Push seems to generate a louder value even when you approach it very gently and "squeeze" it harder when playing. This is very unnatural to say the least regardless of having experience with many real instruments and controllers, and makes it pretty impossible to play anything predictably. This really needs to get fixed.
i'm experiencing similar intermittent issues with velocity/dynamics...

Re: Anyone else find the Push 2 unplayable?

Posted: Mon Nov 30, 2015 7:51 am
by starving student
any word on when the issues will be fixed?

Re: Anyone else find the Push 2 unplayable?

Posted: Mon Nov 30, 2015 9:30 am
by molefonken
Guess I'll wait until this problem is sorted out before I buy the push 2.. Seems like the biggest issue so far.

Re: Anyone else find the Push 2 unplayable?

Posted: Mon Nov 30, 2015 10:51 am
by jobinho
I'm wondering whether this is an issue affecting only a number of units?

None of the reviews have picked up on it and many users seem happy with the playability / dynamic response.

I have one on order so am keen to find out myself. if those who have contacted Ableton could keep us posted on what they say that'd be great.

Re: Anyone else find the Push 2 unplayable?

Posted: Mon Nov 30, 2015 11:00 am
by sowhoso
JPacker555 wrote: Hoping its just defective
send it back and replace while you can. considering all the high praise videos out there its gotta be defective. no problems here with P2

best wishes!

Re: Anyone else find the Push 2 unplayable?

Posted: Mon Nov 30, 2015 3:25 pm
by tedlogan
viewtopic.php?f=55&t=218344&start=15

In an older thread, a user reported that the devs have confirmed that there is a bug concerning unwanted loud velocities when playing very softly sometimes.

Re: Anyone else find the Push 2 unplayable?

Posted: Mon Nov 30, 2015 5:45 pm
by Buleriachk
tedlogan wrote:viewtopic.php?f=55&t=218344&start=15

In an older thread, a user reported that the devs have confirmed that there is a bug concerning unwanted loud velocities when playing very softly sometimes.
I've noticed this in the beta also...