Push 2 / Windows 7 (x64) - USB Device not recognized.

Come here to discuss Push with other users.
For tech support, please head to http://www.ableton.com/help
Post Reply
FatAgnus
Posts: 4
Joined: Tue Dec 15, 2015 2:44 pm

Push 2 / Windows 7 (x64) - USB Device not recognized.

Post by FatAgnus » Tue Dec 15, 2015 3:07 pm

Hi,

I've just traded my Push 1 up to a Push 2. Got it last Thursday.. Plugged it in, Live Recognised it and updated the firmware, the Push 2 rebooted and then....... nothing. Not even a logo on the Push's screen.

I tried turning it off and then on again, but each time I got a "USB device not recognized" notification on my task bar and a blank screen on the Push 2. Until, on the 10-11th attempt, my push 2 sprang into life and worked perfectly with Live. "Yay", I thought, "problem solved.." and I played away merrily..

Until, that is, I turned everything off for the night.

When I powered everything up again the next day, I was back to square one, with the PC reporting "USB device not recognized". And, again, it took a great many attempts (cycling the power, un-plugging and re-plugging the USB cable, etc) before it would work again.

I've tried un-installing the drivers (as per the Ableton help). I've tried different USB cables (and each time I've made sure it is plugged in fully). I've tried with and without the PSU and I've tried the Push 2 on another PC. And I've made sure my PC has all the current updates. In every case it takes me about 10 (on average) attempts to get it to work.

I emailed Ableton support (last Saturday) but I've not had a reply yet. The situation is very frustrating as I have to send my Push 1 in soon, but I don't want to let it go until I can get the issue with the Push 2 resolved.

Sooo... I was wondering if anyone else had seen an issue like this and if they'd managed to solve it.

Any help would be appreciated.

Tarekith
Posts: 17456
Joined: Fri Jan 07, 2005 11:46 pm
Location: Ableton Forum Administrator
Contact:

Re: Push 2 / Windows 7 (x64) - USB Device not recognized.

Post by Tarekith » Tue Dec 15, 2015 3:55 pm

Sadly it does sound like a dud unit based on what you're saying. Hopefully support will get back to you shortly with some suggestions.

FatAgnus
Posts: 4
Joined: Tue Dec 15, 2015 2:44 pm

Re: Push 2 / Windows 7 (x64) - USB Device not recognized.

Post by FatAgnus » Tue Dec 15, 2015 5:01 pm

I suspect you're right, that's my feeling too :cry:

Still nothing from Ableton Support.

nen77
Posts: 7
Joined: Thu Dec 27, 2007 7:50 pm
Location: Mannheim - Germany

Re: Push 2 / Windows 7 (x64) - USB Device not recognized.

Post by nen77 » Tue Dec 15, 2015 10:29 pm

Hello! Have you seen this info (the usb part of troubleshooting / further Troubleshooting):
https://www.ableton.com/en/help/article/setup-push2-win

Maybe here also some useful infos:
https://www.ableton.com/answers/push-2- ... om-simpler

FatAgnus
Posts: 4
Joined: Tue Dec 15, 2015 2:44 pm

Re: Push 2 / Windows 7 (x64) - USB Device not recognized.

Post by FatAgnus » Wed Dec 16, 2015 12:18 pm

Thanks nen77,

Thing is.. it all works perfectly on the odd occasion that Push is recognised by my PC.

I've already tried everything in the troubleshooting guide. Sadly, it hasn't made any difference.

A friend of mine has also bought a Push 2, so I'm going to try his one on my PC to see if it works any better. Then at least I'll hopefully know if it's a duff Push 2 or not.

Still nothing from Ableton Support.

nen77
Posts: 7
Joined: Thu Dec 27, 2007 7:50 pm
Location: Mannheim - Germany

Re: Push 2 / Windows 7 (x64) - USB Device not recognized.

Post by nen77 » Wed Dec 16, 2015 1:19 pm

Do you use an USB-hub or "direct" into your PC? Many hubs using a power supply, but working even without one attached.

I had the same issue on my Win 7 (x64) system, had to restart or replug many times before working, but with the addition that Push 2 wasn't showing the waveforms & meters in the display. The troubleshooting guide didn't help me with the usb issue, too.

The solution for me - i formated my system & made a clean install of Win 10 x64 (after upgrading) - works perfect now, Push 2 is showing all the waveforms & in the mix mode showing the meters! (maybe just a clean (re-) install of Win 7 x64 would have worked, too). Push 2 is recognized every time instantly after starting Live 9.5. I think after a long time of not formatting my system something was wrong with my USB drivers. Hope this helps you somehow.

p.s. did you try the Live 9.5 Beta, maybe they are already working on the issue, today a new Beta (Live 9.5.1b5) was released.

mj17
Posts: 16
Joined: Thu Nov 29, 2007 10:33 pm

Re: Push 2 / Windows 7 (x64) - USB Device not recognized.

Post by mj17 » Thu Dec 17, 2015 7:09 pm

I have this exact issue. And it's driving me crazy.

FatAgnus
Posts: 4
Joined: Tue Dec 15, 2015 2:44 pm

Re: Push 2 / Windows 7 (x64) - USB Device not recognized.

Post by FatAgnus » Fri Dec 18, 2015 6:53 pm

As it turns out you were bang on the money, nen77

I eventually managed to get Push working with my desktop PC by uninstalling and then reinstalling my motherboard's USB drivers. This forced ALL of the device drivers to update (keyboard, mouse, Push 2, etc...). And once I'd rebooted, presto! Everything working as it should.

Then I got a reply from Ableton support, telling me there was a known issue with the Push 2 on Windows and that it's been fixed in a version of the firmware that ships with Live Beta 9.5.1b3 and later. Sure enough this is mentioned in the release notes: "Push 2 Firmware updated to v1.0 build 45. This fixes a problem where the hardware would sometimes fail to initialize on Windows."

So I decided to see if this would fix the issue on my laptop, as it would be easier than trying to reinstall all the USB drivers on that machine too.

I downloaded and installed the newest beta (9.5.1b5) on my desktop, connected the Push 2 and allowed Live to update the firmware. I then disconnected the Push and moved it to my laptop (Still running Live 9.5), and I'm pleased to say it now works 100% without having to do anything else!!

Anyway.. I'm now a very happy Push 2 user (It's utterly gorgeous) and my Push 1 will be going back to Ableton first thing Monday :D

Hope this will also solve your issues, mj17

Thanks again nen77 for all your input.

nen77
Posts: 7
Joined: Thu Dec 27, 2007 7:50 pm
Location: Mannheim - Germany

Re: Push 2 / Windows 7 (x64) - USB Device not recognized.

Post by nen77 » Sat Dec 19, 2015 8:52 pm

Glad to hear the news - made my day, you are welcome! Great that they fixed it with the firmware for other users with the next official update, too! Curious for your new tracks. :)

lovelight
Posts: 240
Joined: Thu Oct 13, 2005 9:01 pm
Contact:

Re: Push 2 / Windows 7 (x64) - USB Device not recognized.

Post by lovelight » Fri Dec 25, 2015 9:48 pm

uninstalling and then reinstalling my motherboard's USB drivers ???

this shouldent be like this.... reconfig your computer system and bios and motherboard for Live 9.5 and push 2 to work, this last update has made people gone crazy with there system, including me, to get everything working for and DAW update that works fine before ( 9.2.3).



https://www.facebook.com/AbletonPushVstRacks/


win 10, 64 bit, 16 gb ram, intel 8xcore i7-4790 cpu 3.60zh, propellerhead balance
http://lovelight.biz/

Tlaloc
Posts: 1
Joined: Thu Oct 13, 2016 4:54 pm

Re: Push 2 / Windows 7 (x64) - USB Device not recognized.

Post by Tlaloc » Mon Nov 28, 2016 12:19 pm

I had this problem. And I figured out the problem was my Graphic Card driver was not installed/updated properly. I uninstalled it and then find the update version in internet. I installed it and now my Push2 is working fine.
Alberto.

Post Reply