Page 1 of 2

Push 2 not lighting up ...

Posted: Thu Jan 07, 2016 12:40 pm
by Drexciya
First post here for me.

For some reason it's really hit or miss for my push 2 starting up properly.
I have tried starting Live 9.5 first and turning push 2 on first. But it doesn't matter in which order I do things the push will not start up. Sometimes it does sometimes not.
I have checked the usb cable and it's fine.

Hope someone can help as this is driving me crazy.

Re: Push 2 not lighting up ...

Posted: Fri Jan 08, 2016 1:14 am
by sparky12
Make sure your USB cable is in properly. It should go in very deeply.

Re: Push 2 not lighting up ...

Posted: Sun Jan 10, 2016 7:23 pm
by Drexciya
I have checked the usb cable a few times and it's plugged in properly.

If I pull the cable out then reconnect it then it works fine but I really shouldn't have to do that.

Re: Push 2 not lighting up ...

Posted: Mon Jan 11, 2016 3:36 am
by Pandamonium
Yep, same problem here, need to power the Push 2 off and on to get it to recognise Ableton is on. Doesn't happen on Push 1 using exact same setup and USB cable. Very annoying. Maybe I have a faulty unit that needs to be returned?

Re: Push 2 not lighting up ...

Posted: Mon Jan 11, 2016 5:38 pm
by [jur]
You should contact

Re: Push 2 not lighting up ...

Posted: Wed Jan 13, 2016 9:26 am
by nen77
Hello! Did you check that post? --> viewtopic.php?f=55&t=219164

best wishes!

Re: Push 2 not lighting up ...

Posted: Wed Jan 13, 2016 9:36 am
by Pandamonium
Yep. seems like a known problem on Windows, but I'm on Mac.. Still no reply from Ableton Support

Re: Push 2 not lighting up ...

Posted: Wed Jan 27, 2016 2:27 am
by Breaks Dude
Mine acts the same way from time to time. Mac OSX

Re: Push 2 not lighting up ...

Posted: Fri Jan 29, 2016 8:19 pm
by 4T
I'm new to both Ableton & Push 2 & I'm also having this problem. Was just making a beat and then I noticed that the main screen was blank [off?] but all other pad lights where on & working as expected.

May need to contact support if it's a defective.. :(

I'm on Windows 7 if that makes a difference

Re: Push 2 not lighting up ...

Posted: Mon Feb 01, 2016 1:29 pm
by Drexciya
I hope I've solved this.....

I followed the setting up link on ableton's website.

In the end I found the thing that helped most was starting up live first then turning on the push 2. Instead of the other way around.

Hope this helps. ...

Re: Push 2 not lighting up ...

Posted: Sat Feb 20, 2016 9:57 pm
by cskracer
Starting a day or so ago this has started happening on my Push 2.

Not sure if it's related to the latest beta or not. I'm running 9.5 Suite + the 9.6b2. At one point Push updated its firmware and I followed the instructions on the screen.

Now whenever I fire up Live, whether it be Suite or the Beta the Push simply sits at the logo or goes to a blank screen.

I've tried everything I can think of:

1. Re-seating the USB cable in the Push multiple times.
2. Changing the order I fire up Push/Live.
3. Followed the troubleshooting guide by deleting the entries for Push in the Device Manager to force Push to update the driver again. Worked once, then as soon as I re-started Live it stopped working once more. Deleting the entries in the Device Manager no longer works and I can't force an update as when I navigate to the directory suggested by Ableton (C:\Program Data\Ableton) the directory is empty - there's nothing to fire off.
4. Pulled out all other USB devices from my machine, except my Focusrite USB Audio card.
5. Tried moving the Push to different USB ports.
6. Turned the computer on and off again.

I did notice whilst trawling through the Device Manager under Software Devices that there are a number of entries entitled Live and Port (latter could be wrong...typing this from my laptop) and they have warning symbols on them. Opening them up they are saying something about not being able to migrate the device.

I've sent a support email to Ableton, but as it's a weekend I doubt I'll hear from them until late Monday my time, so if anyone else can think of something I've missed I'm all ears. I'll have a crack at updating my motherboard USB drivers next, but after that I'm stumped.

Re: Push 2 not lighting up ...

Posted: Sun Feb 21, 2016 6:39 pm
by 4T
I ended up returning my unit as 'faulty' because regardless of all the suggestions, it shouldn't be this complicated. I've own both MPC Ren & Maschine MK2 and never had issues with either.

Shouldn't it be as simple as switching it on and Ableton recognising so?

I'll report back once I recieve my replacement over the next few days so I can confirm wether it was my unit or not.

Side note: I also noticed that when it did come on, my Push 2 wasn't showing sample waveforms or mixer volume meter activity. This is what prompted me to finally go ahead and return it even tho Ableton support suggested it was my system and had something to do with the seperate display driver that Push 2 uses.

Got the usual response; update my graphics card, check I have the latest version of windows etc.

If it does turn out to be my system, I'll be shocked. It's not modern spec but it's more than capable of powering and operating a fancy midi controller.

Spec: Windows 7 sp 1 [32bit] [4gb RAM] [Core2Duo @3Ghz] Nvidia Graphics Card

Re: Push 2 not lighting up ...

Posted: Mon Feb 22, 2016 9:41 pm
by amere
Having same issue on a mac. (10.11.3) ableton 9.6 (also tried with latest beta 9.6.1b2)
  • blank screen until I hit mix button and or session button
    instruments do not show unless I press a 2nd row button
    no mix volume showing
    no wave form loading in simpler
    firmware says version 0.0.0 (that can't be right?)
4 days, no reply from support.

Re: Push 2 not lighting up ...

Posted: Tue Feb 23, 2016 1:47 am
by jestermgee
One thing I thought I would mention for Windows users

I had a false detection from my antivirus for the PushProcess.exe (or whatever its called) and it blocked it from running. This caused Push to still behave as push (could trigger pads) but the display was blank. It would sometimes start and sometimes not when loading Live.

I added an exception to the AV for the Ableton install path and it's been fine since.

Could be the issue in some cases on windows at least?

Re: Push 2 not lighting up ...

Posted: Tue Feb 23, 2016 2:04 pm
by cskracer
Not in my case. I don't run an AV.

No response from support yet for me either.