M4L Stability

Questions and discussion about building and using Max for Live devices
Post Reply
19oclock
Posts: 54
Joined: Thu Aug 21, 2014 5:40 pm

Re: M4L Stability

Post by 19oclock » Wed Dec 17, 2014 9:52 pm

tecolo wrote:
19oclock wrote:M4L is no good to me in the traditional sense. Devices that span more than three pipes are suspect. I have experience using commercial M4L releases that crash frequently. If the professional developers cannot get it going right then I won't trust it.

This happens on my desktop and my laptop. Both are Windows 7 32bit machines.

Since I've ditched the commercial stuff things are better. Use M4L with caution if you are a performer!
But the whole M4l idea was attracting to me and i jumped on to it because of m4l. I am working on it ocassionaly at friend studio because i am tryingf to translate my projects to other DAW.

I just realized that now not even the latest Henke LFO m4l device doesn't work without error. If you save it inside of clip and recall clip in other project you get window with weird error. I'll report it to Henke himself..

Oh crap...

Is there any i mean any official reply on this issue...I see super long post of fixes on Live itself on Ableton suite but m4l is mentioned rarely..
Use M4L but if you use more than, say, 8 pipes I would start reconsidering how you are building the device. M4L doesn't provide a good means of managing processing and I believe most issues stem from this.

eyeknow
Posts: 5822
Joined: Fri Jul 15, 2005 6:16 am

Re: M4L Stability

Post by eyeknow » Wed Dec 17, 2014 10:58 pm

Just as an update on my end, I still get crashes with M4L stuff sometimes and it's not just one kind of M4L device. It's really quite random here.

Reimund
Posts: 12
Joined: Sat Apr 04, 2009 12:48 pm

Re: M4L Stability

Post by Reimund » Thu Dec 18, 2014 9:01 am

eyeknow wrote:Just as an update on my end, I still get crashes with M4L stuff sometimes and it's not just one kind of M4L device. It's really quite random here.
same here but i get the crashes not only sometimes but almost everytime i load a m4l device. funnily, when i restart live after the first crash the m4l devices seem to load without crashes. in the end i got so frustrated that i uninstalled max and my m4l packs and now use live without the m4l functionality. of course, i would like to use m4l again but i won't install it again until the crashes are fixed. however, i'm not sure when this will be given that these crahes have been reported for months now and no fix has appeared.

tecolo
Posts: 60
Joined: Tue Jun 03, 2014 1:21 pm

Re: M4L Stability

Post by tecolo » Fri Dec 19, 2014 12:01 pm

Reimund wrote:i'm not sure when this will be given that these crahes have been reported for months now and no fix has appeared.
Yep it's quite bizarre... :cry: Not even a single hint from official developers.

Angstrom
Posts: 14674
Joined: Mon Oct 04, 2004 2:22 pm
Contact:

Re: M4L Stability

Post by Angstrom » Fri Dec 19, 2014 1:42 pm

I've had a hint from the developers, but I know they don't like to have private communications repeated here. I'll paraphrase what I was told in this case - and you can assume I have mangled it in some way so that it barely aligns with the reality.

In some circumstances, most often on Windows machines: When you start Live and it attempts to immediately load a set (perhaps your default set, or perhaps a recovery of an undo) and that set contains a Max device and Max is not yet initialised and available the referenced objects/properties/classes aren't yet set - so Live will crash. At that point it will leave an undo recovery file which contains a Max reference, which, if you try to load it and max is still not yet loaded, will crash again, and then will crash again... etc.

I know you are sat there saying "What!?" and your face is looking like a cross between a beetroot and a walnut. But that's what's happening according to Ableton.

The workaround : don't have Max devices in default sets. Sit on hands, shake head slowly, wait and hope.

S4racen
Posts: 5238
Joined: Fri Aug 24, 2007 4:08 pm
Location: Dunstable
Contact:

Re: M4L Stability

Post by S4racen » Fri Dec 19, 2014 3:57 pm

Angstrom wrote:I've had a hint from the developers, but I know they don't like to have private communications repeated here. I'll paraphrase what I was told in this case - and you can assume I have mangled it in some way so that it barely aligns with the reality.

In some circumstances, most often on Windows machines: When you start Live and it attempts to immediately load a set (perhaps your default set, or perhaps a recovery of an undo) and that set contains a Max device and Max is not yet initialised and available the referenced objects/properties/classes aren't yet set - so Live will crash. At that point it will leave an undo recovery file which contains a Max reference, which, if you try to load it and max is still not yet loaded, will crash again, and then will crash again... etc.

I know you are sat there saying "What!?" and your face is looking like a cross between a beetroot and a walnut. But that's what's happening according to Ableton.

The workaround : don't have Max devices in default sets. Sit on hands, shake head slowly, wait and hope.
This sounds like the first step to a fix....

Cheers
D

tecolo
Posts: 60
Joined: Tue Jun 03, 2014 1:21 pm

Re: M4L Stability

Post by tecolo » Fri Dec 19, 2014 10:29 pm

Angstrom wrote:I've had a hint from the developers, but I know they don't like to have private communications repeated here. I'll paraphrase what I was told in this case - and you can assume I have mangled it in some way so that it barely aligns with the reality.

In some circumstances, most often on Windows machines: When you start Live and it attempts to immediately load a set (perhaps your default set, or perhaps a recovery of an undo) and that set contains a Max device and Max is not yet initialised and available the referenced objects/properties/classes aren't yet set - so Live will crash. At that point it will leave an undo recovery file which contains a Max reference, which, if you try to load it and max is still not yet loaded, will crash again, and then will crash again... etc.

I know you are sat there saying "What!?" and your face is looking like a cross between a beetroot and a walnut. But that's what's happening according to Ableton.

The workaround : don't have Max devices in default sets. Sit on hands, shake head slowly, wait and hope.
Jesus and Maria...so is there a way to "preload" most of the stuff from m4live (objects/properties/classes) so it won't wait and crash whole Ableton.

Ableton developers don't want to repeat themselves? I mean what the heck? Are they serious? If they don't want to repeat then they should just say this officially at their website. Clearly. So basically something like "look Win people don't buy it for M4l because it is not working at the moment"..

This is just ridiculous.


I have found interesting article by myself when i was seeking for more info about this. And this isn't first article i have found about issue. It seems that quite a few 3rd party developers have issues with m4l and win platfrom.

Look here: http://www.wavedna.com/known-issue-max- ... thm-crash/
this is a short copy paste from article:

Back in September we found a bug that affects only Windows users. The issue: when you load our Liquid Clips Max Patch into Ableton it will crash unexpectedly. We tested on a few systems here at the office with several Ableton Live and Max For Live versions and combos. We found that any Windows machine that had Max For Live 6.1.7 / 6.1.8 / 6.1.9 and also Ableton Live Version 9.1.4 / 9.1.5 /9.1.6 (both 32 and 64 bits) contained this bug.

For the past few months we have been in constant contact with Ableton and Cycling ’74 and they had been testing this issue pretty thoroughly. From many hours of testing and from some help from a user who was having this issue, we have a working temporary fix. It’s temporary because we still haven’t discovered the root problem. Fixing the root issue will take a little longer due to the fact that we have to re-connect with Ableton and Cycling ’74 and get their opinion on what we can do for the next step.


p.s. don't bother - fix is only for WaveDNA plugin. I tried it and it did not helped..

Out of curiosity i have a question. So basically am i assuming it right? Mac people don't have these weird problems? Yes or no?

Another question. Does people with win8 have greater stability in max then these on win 7 platform? Can anyone say something more about this? Someone anyone? What are your experiences...

Because789
Posts: 440
Joined: Thu Apr 28, 2011 1:26 pm

Re: M4L Stability

Post by Because789 » Fri Dec 19, 2014 11:50 pm

M4L devices run very stable on my Win 8.1 machine. Zero crashes when loading and using M4L devices, only a few crashes while messing around in patches and that was most of the time caused by my own stupidity.
Live 9.5 (64bit), Max 7.0.6, Windows 10, Push 2, Korg electribe2, Bass Station II, Launch Control XL, Faderfox DJ3

M4L

eyeknow
Posts: 5822
Joined: Fri Jul 15, 2005 6:16 am

Re: M4L Stability

Post by eyeknow » Sat Dec 20, 2014 2:52 am

tecolo wrote:
Reimund wrote:i'm not sure when this will be given that these crahes have been reported for months now and no fix has appeared.
Yep it's quite bizarre... :cry: Not even a single hint from official developers.
Plus, I used to be quite active over at the beta forum and THAT is a dead zone. Maybe they are up to baking something new??? Yeah, prolly wishful thinking :lol: Fabriziopoce has already mentioned though that there is an awareness on behalf of ableton, max and max developers. Maybe they can figure it out

Anyhoo, someone brought up the part about crashing and then it being fine the next time. Yeah, I've experienced that too but by and large I just try not to use M4L stuff for the time being. Sad really...

tecolo
Posts: 60
Joined: Tue Jun 03, 2014 1:21 pm

Re: M4L Stability

Post by tecolo » Sat Dec 20, 2014 11:52 am

Because789 wrote:M4L devices run very stable on my Win 8.1 machine. Zero crashes when loading and using M4L devices, only a few crashes while messing around in patches and that was most of the time caused by my own stupidity.
This is useful info. Thanks. Is there anyone else who can confrim stable m4l environment at Win8.

May i ask what samplerate you are using and what is your ASIO buffer setting?


Thanks a lot guys!!

salmonito
Posts: 15
Joined: Wed Dec 03, 2014 2:09 am

Re: M4L Stability

Post by salmonito » Mon Dec 22, 2014 10:26 pm

Crashes after crashes. W7 64b. I tried granulator 2, instant haus, drum synth from max4live. Saved the project (all liveinstruments, effects + max4live). Later, the project cannot be opened 50% of the time, live crashes after max4live splash screen "serious error". I could live with this if this was a free product. This is not funny and a very unprofessional error handling from live and m4l.

tecolo
Posts: 60
Joined: Tue Jun 03, 2014 1:21 pm

Re: M4L Stability

Post by tecolo » Tue Dec 23, 2014 11:29 am

salmonito wrote:Crashes after crashes. W7 64b. I tried granulator 2, instant haus, drum synth from max4live. Saved the project (all liveinstruments, effects + max4live). Later, the project cannot be opened 50% of the time, live crashes after max4live splash screen "serious error". I could live with this if this was a free product. This is not funny and a very unprofessional error handling from live and m4l.
I feel your pain. Can anyone with win8 confirm that loading granulator 2, MonoSequencer, and drum synth doesn't crash your system - assuming that you are loading previously saved project. And try this - try to load at least two or three different projects and then try to load one conatining m4l devices.

And also try to save m4l devices inside a clip and recall it in other projects..


By reading some infos here i am under assumption that Win8 users have better experience with m4l then people at win7. I would like to confirm that..

salmonito
Posts: 15
Joined: Wed Dec 03, 2014 2:09 am

Re: M4L Stability

Post by salmonito » Thu Dec 25, 2014 3:00 am

Well it's not the combination that a problem. I can have instant haus in my project or a convolution reverb. Opening project crashes live 50% of the time. A presence of max4live device/effect is the problem.

eyeknow
Posts: 5822
Joined: Fri Jul 15, 2005 6:16 am

Re: M4L Stability

Post by eyeknow » Thu Dec 25, 2014 3:16 am

Let's face it guys, it's borked :lol:

tecolo
Posts: 60
Joined: Tue Jun 03, 2014 1:21 pm

Re: M4L Stability

Post by tecolo » Sun Dec 28, 2014 8:56 am

eyeknow wrote:Let's face it guys, it's borked :lol:
Not funny joke believe me..can we stay on topic please..

Post Reply