FIXED New Live crashes Soundtoys 5 plugs.

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
XSIMan
Posts: 552
Joined: Wed Nov 18, 2009 7:22 pm
Location: England
Contact:

FIXED New Live crashes Soundtoys 5 plugs.

Post by XSIMan » Wed Oct 21, 2015 2:43 am

FIXED
Update

Soundtoys has released a new version of Soundtoys 5 for Windows to fix issues with Windows 10 and Live 9.2.3


Just installed Ableton Live 9.2.3 on windows 10 now my Soundtoys 5 plugins crash it soon as I try to drag one onto a track. I installed Live 9.2.3B4 Beta and that crashed every time while scanning plugins at loadup.
Last edited by XSIMan on Tue Oct 27, 2015 6:02 am, edited 1 time in total.

steverido
Posts: 20
Joined: Mon May 10, 2010 7:30 am

Re: New Live crashes Soundtoys 5 plugs.

Post by steverido » Wed Oct 21, 2015 7:54 am

XSIMan wrote:Just installed Ableton Live 9.2.3 on windows 10 now my Soundtoys 5 plugins crash it soon as I try to drag one onto a track. I installed Live 9.2.3B4 Beta and that crashed every time while scanning plugins at loadup.

Fixed all my problems by reinstalling Live 9.2 from months ago.
I have got the same issue too. I have opened up a bug report with Ableton through the Beta portal and have also raised a ticket with Soundtoys.

I will report back when I hear anything.

CDAD
Posts: 1
Joined: Sat Oct 17, 2015 1:21 pm

Re: New Live crashes Soundtoys 5 plugs.

Post by CDAD » Thu Oct 22, 2015 6:27 am

XSIMan wrote:Just installed Ableton Live 9.2.3 on windows 10 now my Soundtoys 5 plugins crash it soon as I try to drag one onto a track. I installed Live 9.2.3B4 Beta and that crashed every time while scanning plugins at loadup.

Fixed all my problems by reinstalling Live 9.2 from months ago.
I am having the same problem with LittleAlterBoy and Live 9.2.3 (and Windows 10). Might try reinstalling tonight.

mmorgan
Posts: 180
Joined: Sat Oct 20, 2012 6:49 pm
Location: Bellingham, WA

Re: New Live crashes Soundtoys 5 plugs.

Post by mmorgan » Thu Oct 22, 2015 1:34 pm

Do you have an iLok? The most recent update to Studio One caused all kinds of problems for people on Win 10 using an iLok. IIRC Soundtoys was one developer whose products were causing problems.

The initial workaround was to set the app to Windows 8.1 Compatibility mode.

There is a lot of work being done to get all the plugins and Studio One itself updated.
Michael Morgan | pearl hour project
.........................................................
Intel i7-2600 @3.4GHz; 16G Ram; Win 10-64; Live 9.5
RME-Fireface UFX; Machine II; APC40; MPK25;
Guitars and Amps

XSIMan
Posts: 552
Joined: Wed Nov 18, 2009 7:22 pm
Location: England
Contact:

Re: New Live crashes Soundtoys 5 plugs.

Post by XSIMan » Thu Oct 22, 2015 4:22 pm

Thanks for reporting it to Ableton.

I also have Slate Digital and Eventide plugins they use ilok too and they cause no problems with the latest Ableton or beta under Windows 10 although I sometimes have to manually start ilok licenser by running windows services. I think ilok not auto starting is only a bug with Windows 10.

crystalmsc
Posts: 883
Joined: Fri Feb 11, 2011 4:47 pm
Contact:

Re: New Live crashes Soundtoys 5 plugs.

Post by crystalmsc » Thu Oct 22, 2015 10:54 pm

Thank you for the heads up, I turned auto update off and stay with 9.2.2 for now. Everything works like charm.
Kaossilatron - Voicillator
Station: Ableton Live 10 Suite, Obscurium, Push 2, Ultranova, MS-20m, Wavedrums

XSIMan
Posts: 552
Joined: Wed Nov 18, 2009 7:22 pm
Location: England
Contact:

Re: New Live crashes Soundtoys 5 plugs.

Post by XSIMan » Fri Oct 23, 2015 5:34 pm

Mine auto updated to the latest version and wouldn't boot at all. Put it in compatibility mode for Windows 8 and now the latest version works for Soundtoys and Live + Win 10. Thanks for the reminder about compatibility mode Mmorgan, I forgot to try that.

Just realised running in compatibility mode stops the Soundtoys Rack doing drag and drop. Reverting back to Live 9.2.1 and disabling the auto update.

kitekrazy
Posts: 731
Joined: Sat Jan 16, 2010 7:16 pm

Re: New Live crashes Soundtoys 5 plugs.

Post by kitekrazy » Sat Oct 24, 2015 6:23 pm

I'd say the problem lies with W10. I see problems that exist in 10 but work in W7 with other DAWs.

XSIMan
Posts: 552
Joined: Wed Nov 18, 2009 7:22 pm
Location: England
Contact:

Re: New Live crashes Soundtoys 5 plugs.

Post by XSIMan » Mon Oct 26, 2015 5:54 am

Soudntoys say they are working on a fix.

csl
Posts: 29
Joined: Mon Jul 04, 2005 3:00 pm
Location: Newcastle, England.
Contact:

Re: New Live crashes Soundtoys 5 plugs.

Post by csl » Mon Oct 26, 2015 5:54 pm

They've just released a new version that fixes this issue. All fine in Live 9.2.3 on Win 10. :)

jestermgee
Posts: 3248
Joined: Mon Apr 26, 2010 6:38 am
Contact:

Re: New Live crashes Soundtoys 5 plugs.

Post by jestermgee » Mon Oct 26, 2015 10:27 pm

XSIMan wrote:Thanks for reporting it to Ableton.

I also have Slate Digital and Eventide plugins they use ilok too and they cause no problems with the latest Ableton or beta under Windows 10 although I sometimes have to manually start ilok licenser by running windows services. I think ilok not auto starting is only a bug with Windows 10.
I have Eventide UltraReverb and this causes crashes opening projects on occasion. A project will crash on load but if I try it again a second time it opens. Ableton said from a crash report it was the UltraReverb plugin so could be related to iLok but I have a few other plugs on ilok and these do not cause issues and also UltraReverb only seems to cause issues when in large projects (projects with EastWest content seems to do it).

XSIMan
Posts: 552
Joined: Wed Nov 18, 2009 7:22 pm
Location: England
Contact:

Re: New Live crashes Soundtoys 5 plugs.

Post by XSIMan » Tue Oct 27, 2015 6:04 am

csl wrote:They've just released a new version that fixes this issue. All fine in Live 9.2.3 on Win 10. :)
Thanks for the heads up. I've just installed the new version of Soundtoys and Live 9.2.3 and they now play perfect together.

Thanks to Soundtoys for a fast fix.

Post Reply