Push 2 driver installation fails on Win 7 -- WORKAROUND

Come here to discuss Push with other users.
For tech support, please head to http://www.ableton.com/help
Post Reply
ark
Posts: 1348
Joined: Thu Feb 26, 2009 4:25 pm
Location: New Jersey, USA
Contact:

Push 2 driver installation fails on Win 7 -- WORKAROUND

Post by ark » Fri Nov 06, 2015 3:53 pm

Just received Push 2. Connected it to the computer, launched Live, and it autoupdated the firmware. After that, most of the time, when I connected Push 2 to the computer, I'd get a complaint from Windows about failed device-driver installation.

Here's the workaround: Connect Push 2 to its power supply, turn it on, and then connect it to the computer. Works every time.

I've filed a bug report.

zsklar
Posts: 33
Joined: Sat Jul 23, 2005 9:32 pm

Re: Push 2 driver installation fails on Win 7 -- WORKAROUND

Post by zsklar » Fri Nov 06, 2015 5:53 pm

I've had Push 2 in my studio for 5 days just collecting dust because for the life of me I can't get Live 9.5 to not crash every time I turn on Push 2. I am beyond frustrated. I've tried pretty much everything. I was on a tech support call with Ableton in Berlin for 2 hours with still no luck. I have a Windows 7 PC. It works fine with my Macbook Pro.

There is some sort of driver issue. It's all I can think of. I really don't want to return this to the store. I was so excited to use Push 2 with the new features.

Anyone have any ideas other than the reinstalling Ableton and the Push 2 drivers. I've done that countless times.

Thanks in advance,

Zach

Lovelights
Posts: 53
Joined: Thu Jan 22, 2015 9:09 pm

Re: Push 2 driver installation fails on Win 7 -- WORKAROUND

Post by Lovelights » Fri Nov 06, 2015 7:26 pm

zsklar wrote:I've had Push 2 in my studio for 5 days just collecting dust because for the life of me I can't get Live 9.5 to not crash every time I turn on Push 2. I am beyond frustrated. I've tried pretty much everything. I was on a tech support call with Ableton in Berlin for 2 hours with still no luck. I have a Windows 7 PC. It works fine with my Macbook Pro.

There is some sort of driver issue. It's all I can think of. I really don't want to return this to the store. I was so excited to use Push 2 with the new features.

Anyone have any ideas other than the reinstalling Ableton and the Push 2 drivers. I've done that countless times.

Thanks in advance,

Zach
completely the same problem with me and push 2 and a crashing live 9.5, and when it work it sky rocket the cpu, and ive got a very big and fast pc and win 10 :(

john gordon
Posts: 2680
Joined: Tue Nov 11, 2003 12:24 am
Location: Delaware

Re: Push 2 driver installation fails on Win 7 -- WORKAROUND

Post by john gordon » Fri Nov 06, 2015 7:51 pm

Leave it to good ole Windows! People never learn.

Mark Williams
Posts: 226
Joined: Sun Aug 10, 2014 2:43 pm
Location: Deal, Kent

Re: Push 2 driver installation fails on Win 7 -- WORKAROUND

Post by Mark Williams » Fri Nov 06, 2015 11:25 pm

and Apple with the El Capitan update worked so well too...
Live 10,Push 2, Maschine MK3 & KK S61 MK2, Focusrite Scarlett 18i20, Softube Console 1 Mk2, Deepmind 12D, K-2,Roland MC-707, Komplete 12, Minitaur,TC Electronics M1XL, Waves Audio Beta tester
Get 10% off Waves Plugins https://www.waves.com/r/r0z5tks

yur2die4
Posts: 6408
Joined: Sat Oct 03, 2009 3:02 am
Location: Menasha, Wisconsin
Contact:

Re: Push 2 driver installation fails on Win 7 -- WORKAROUND

Post by yur2die4 » Fri Nov 06, 2015 11:29 pm

Yeah, honestly from experience this is one of the few actual issues I've seen from Windows.

Most issues I see people having are from updating Apple computers.

If I were to have theoretically 'learned' anything, it would be that I'm best off with Windows.

Of course neither is superior, but I had to point that out :lol:

H20nly
Posts: 15836
Joined: Sat Oct 27, 2007 9:15 pm
Location: The Wild West

Re: Push 2 driver installation fails on Win 7 -- WORKAROUND

Post by H20nly » Fri Nov 06, 2015 11:39 pm

last night i was attempting to install 9.5. i found that my computer was running like garbage. i looked in Activity Monitor on my Mac and found the Ableton indexing process to be the culprit. i did an end task (or whatever it's called in Apple land) and everything was flying after that.

you might see the same thing in Windows Task Manger. i would encourage you to look and see.

Razz CE
Posts: 71
Joined: Mon May 11, 2015 12:53 am

Re: Push 2 driver installation fails on Win 7 -- WORKAROUND

Post by Razz CE » Sun Nov 08, 2015 1:00 am

Question: when you press Setup on your Push(es) and click on Info, what firmware version do you have? I'm on Firmware 1.0 Build 44 - I think that mine autoupdated but I'm not positive. I can't see waveforms when I load samples in Simpler so I'm just checking possible culprits off the list.
Win 10 x64/16GB/i7 6700k
Live 9 Suite/Cubase Pro 9.5
Audient iD4/Push 2/Steinberg CMC-CH/Launchkey 25

Post Reply