APC 40 MKI Knobs Jitter and Throw is too long after update

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Wbowers
Posts: 83
Joined: Sat Nov 28, 2009 4:57 pm

APC 40 MKI Knobs Jitter and Throw is too long after update

Post by Wbowers » Sat Nov 07, 2015 1:47 pm

Anyone else having this problem? The APC40 MK1 Track and Device Knobs take forever to turn a full rotation and jitter terribly after the 9.5. I have live on two computers one I have not updated and it works fine there. Any confirm this? Thanks

Wbowers
Posts: 83
Joined: Sat Nov 28, 2009 4:57 pm

Re: APC 40 MKI Knobs Jitter and Throw is too long after update

Post by Wbowers » Sat Nov 07, 2015 2:37 pm

I have tried the APC40 with a machine running 9.1 and it works as it should. I also used it in Resolume and mapped it and it works there too..

ShelLuser
Posts: 3790
Joined: Sun Dec 06, 2009 10:26 pm
Location: Wageningen, Netherlands

Re: APC 40 MKI Knobs Jitter and Throw is too long after update

Post by ShelLuser » Sat Nov 07, 2015 6:16 pm

Wbowers wrote:The APC40 MK1 Track and Device Knobs take forever to turn a full rotation and jitter terribly after the 9.5.
I can confirm this somewhat. I compared current behavior with Live 8 and the knobs are definitely less responsive (take longer to rotate) and if you move them more quickly they jitter a bit.

However, I can't comment on 9.2 because I haven't been using my APC all that much lately.

Up until now I haven't really picked this up as something annoying or problematic.
With kind regards,

Peter

Using the 'Power' Trio: Live 10 Suite (+ Push & Max 8 ), Reason 10 and Maschine Mk3 (+ the ultimate Komplete 12).
Blog: SynthFan (under heavy construction!)

Wbowers
Posts: 83
Joined: Sat Nov 28, 2009 4:57 pm

Re: APC 40 MKI Knobs Jitter and Throw is too long after update

Post by Wbowers » Sun Nov 08, 2015 1:38 pm

Update: I noticed that when I map the Midi knobs to a parameter the problem goes away. That points to a problem with the Dynamic midi assign (the ability to float from device to device, or the blue hand) in the remote script. I dont know enough about Remote scripting to fix it though.

For sure on the device jitter on 9.1 and 9.2. I have had many in our user group confirm that. Even when hard mapped it will jitter. Most notorious is Device control Knob 8. I have seen Knobs 3, and 5 do this too.

Such a shame.. I put in a support request. I hope this gets resolved soon. it makes the APC40 unreliable on stage and in the studio. And the MKII feels like a toy so I wont be upgrading to that unless its price fell to about $150.

TYLRbass
Posts: 277
Joined: Tue Aug 30, 2011 8:51 pm

Re: APC 40 MKI Knobs Jitter and Throw is too long after update

Post by TYLRbass » Thu Nov 12, 2015 2:51 am

I have this problem too since anything past 9.1.10. I've been in contact with Ableton Support and they have just now after a lot of back and forth confirmed this bug and should be working on it, crossing my fingers for an update because it effects me with APC40mkII and Push 1 in the studio and for live sets. Being stuck on 9.1.10 with all these new features has me super bummed out.

But anyway, the problem as they explained it was midi values being reported out of order. From what I can tell it's only a problem with the dynamic controls like you guys mentioned. When hard mapped to the very same control you get a smooth action so something is definitely wrong there.

You may notice if your audio buffer size is 128 or less you won't get as much jitter and in my case its hard to detect any at all. This somewhat fixes the problem for now with my APC40mkII but I'm just barely able to pull that off when I'm working and really don't want to give it a shot on stage.

The Push 1 encoders in 9.5 aren't jumpy BUT they have a very similar problem with the throw being too long, about twice as much resolution as my 9.1.10 install.. if you hold shift for fine control you get such a fine control you have to crank the knob all the way around for a single value. Buffer setting doesn't seem to have any effect on with Push 1, but it is a connected issue I believe.

When did you all notice this? I'm good with 9.1.10 but 9.2 and on I can't use. I went as far as re-installing my operating system because I was told the problem was unique to my system and I was willing to try whatever it would take.

Steve E B
Posts: 1
Joined: Tue Dec 01, 2015 3:59 am

Re: APC 40 MKI Knobs Jitter and Throw is too long after update

Post by Steve E B » Sun Dec 06, 2015 11:45 pm

I've been having the same issue here as well. I have an APC40 MK2, all was fine until I updated to 9.5. While using 'little blue hand control' there is tons of jitter and takes nearly 3 1/2 turns to get from 0-127. This makes the controller useless for any sort of automation or effects programming; it's basically an overpriced clip trigger at this point.

If mapped through midi, the issue goes away, although this is a work around it still severely limits the usefulness of the controller. The jitter is much more prominent when turning a knob quickly, if you slowly turn the knob there is little to no jitter at all.

Feeling really frustrated with having spent a lot of money on an otherwise great controller that does not work properly. Please fix soon!

outcast
Posts: 3
Joined: Sun Jun 13, 2010 10:39 pm

Re: APC 40 MKI Knobs Jitter and Throw is too long after update

Post by outcast » Fri Dec 11, 2015 12:15 pm

its not unique to your system. have the exactly same problem. :-( the new script is faulty.
i tried a script from an older installation. not working :-(

tedlogan
Posts: 1343
Joined: Thu Dec 20, 2012 7:23 pm
Location: Leamington Spa, UK
Contact:

Re: APC 40 MKI Knobs Jitter and Throw is too long after update

Post by tedlogan » Fri Dec 11, 2015 12:33 pm

Yes, the throw on my APC40 mk1 is very long, and terrible jitter all over the place. If I don't hardmap the pans to specific parameters, they like to place themselves in the stereofield. I was wondering for a few weeks why the hell some pans would always be off-centre. (Didn't really notice the jitter at first as I only used its crossfader)

Also, maybe because I'm used to Push 2 now, but Push 1's throw, especially macro parameters, take about twice as long to do a full sweep than Push 2.

Live 9.5 / 9.5.1b4

apyssjw
Posts: 38
Joined: Tue Jul 12, 2005 4:50 pm
Contact:

Re: APC 40 MKI Knobs Jitter and Throw is too long after update

Post by apyssjw » Fri Dec 11, 2015 11:00 pm

Yes the same for me, apc40mk1. It's the jitter that's frustrating.

TYLRbass
Posts: 277
Joined: Tue Aug 30, 2011 8:51 pm

Re: APC 40 MKI Knobs Jitter and Throw is too long after update

Post by TYLRbass » Sat Dec 12, 2015 5:05 pm

tedlogan wrote:Also, maybe because I'm used to Push 2 now, but Push 1's throw, especially macro parameters, take about twice as long to do a full sweep than Push 2.

Live 9.5 / 9.5.1b4
Same problem with my Push 1 and confirmed by Ableton support.. Still waiting on a fix, until then 9.5 is pretty useless. Been an Ableton user for years but I feel bad for anyone who has recently purchased a controller + live and ends up with this as their first impression...

Alchemystic
Posts: 18
Joined: Tue Dec 15, 2015 7:35 pm

Re: APC 40 MKI Knobs Jitter and Throw is too long after update

Post by Alchemystic » Tue Jan 19, 2016 4:32 pm

I think I'm having this same problem!! Any updates?

I'm running the 9.6b1 btw, because my bandmate and I have been taking advantage of the Link capability which is tremendous! However that's pushed me to want to get much better at using controllers...so on that journey last Saturday I bought a used apc40 special edition for a sweet price. Tested it out at the shop before bringing it home and all seemed good...

But trying it use it in tandem with my Novation SL MkII 61 I've noticed this strange behavior that when I turn the knob the values seems to jump around and doesn't flow smooth - jittery like several of you have described. It'll also wander for a little bit after I let go, which makes it tough to reliably return an fx rack back to dry. It seems to only affect the "Device Control" knobs for me - so it seems to be related to the blue hand auto control mechanism.

I've tried removing the Novation as a control surface to see if the conflict is related to the two controllers, and turned off the Automap software - didn't change it. Haven't tried uninstalling yet. But I'm working through testing to see if it's something I did, a setting thing somewhere, or what. I also read that taking it apart and cleaning the pots with some canned air might be a good step, tho I'm wary to take it apart unless absolutely necessary.

Sounds like it could be the same thing y'all are describing. Has anyone come up with a solution/resolution for this? I absolutely *LOVE* the way the apc40 feels, the Novation's pots always felt very cheap to me...so I really want to dig in and take full advantage of what this new controller can do...except I have to get it working properly first...>_<

Alchemystic
Posts: 18
Joined: Tue Dec 15, 2015 7:35 pm

Re: APC 40 MKI Knobs Jitter and Throw is too long after update

Post by Alchemystic » Wed Jan 20, 2016 4:59 am

update: fixed my problem by taking it apart and cleaning the pots with contact cleaner and canned air...works like a charm now.

BioMech
Posts: 16
Joined: Sun Nov 08, 2009 10:52 pm

Re: APC 40 MKI Knobs Jitter and Throw is too long after update

Post by BioMech » Fri Apr 08, 2016 11:34 am

Hi,

same problem here : jitter / oscillation when moving a knob on APC40 MK1 - for several months (I thought that my controller was broken).
I noticed that after moving a knob, behaviour is not always the same :
- sometimes it behaves correctly
- sometimes it is like an opposite force to knob action(need to perform several 360° move to obtain desired value)
- sometimes it is an eagerated move => a small action is exagerated (panning for example : 10° left move becoimes 90° LEft move)
- soometimes it continues to move after touching knob (in a non linear up/down movement and sometimes during several seconds).

If it is an HW problem, i think that :
=> it is not linked to dust on one knob as problem occurs on several knobs (and my APC40 is kept clean - cleaned with air can => no change).
=> it might be linked to a problem at SW, microcontroller or ADC - digital potentiometer / clock level, for example (problem should be less similar and behaviour should be more messy).

In my opinion, the explanation about faulty script/SW update seems to be the most credible as exactly the same problem seems to occur to several users at the same time.

It seems that a lot of us observe this problem since live update.

It seems that a lot of us use also push, do you confirm it ?

THis problem is very annoyous, i hope an update will resolve it quickly.


My Configuration :
windows 10 - Core i7 - 16GB RAM
rme fireface 800
apc40 - apc20 - push 1 - komplete kontrol s61

BioMech
Posts: 16
Joined: Sun Nov 08, 2009 10:52 pm

Re: APC 40 MKI Knobs Jitter and Throw is too long after update

Post by BioMech » Fri Apr 08, 2016 11:48 am

An ableton user posted a video describing problem in another topic :
viewtopic.php?f=3&t=219552&view=previous

BioMech
Posts: 16
Joined: Sun Nov 08, 2009 10:52 pm

Re: APC 40 MKI Knobs Jitter and Throw is too long after update

Post by BioMech » Fri Apr 08, 2016 12:34 pm

I make my auto answer, problem seems to be resolved with latest 9.6 beta.
Best :)

Post Reply