Browser search slow in 9.5

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
skioakenfull
Posts: 5
Joined: Mon Mar 14, 2016 8:20 pm

Browser search slow in 9.5

Post by skioakenfull » Mon Mar 14, 2016 9:00 pm

Has anyone got any tips on how to speed up searches in the browser?
It seems to momentarily freeze while I'm typing the word before picking up again.
I thought that the files would be cached making search results immediate..
I'm convinced it used to be faster before the 9.5 update.

Many thanks
Ski

[jur]
Site Admin
Posts: 1597
Joined: Mon Jun 01, 2015 3:04 pm
Location: Ableton

Re: Browser search slow in 9.5

Post by [jur] » Mon Mar 14, 2016 10:12 pm

Hey Ski!
Did you recently add new content in your library like Live Packs?
Most of the time the samples are the type of files that slow down the process.
I haven't noticed 9.5 to be slower in that area, but... maybe I just haven't noticed.
cheers
j.
Ableton Forum Moderator

skioakenfull
Posts: 5
Joined: Mon Mar 14, 2016 8:20 pm

Re: Browser search slow in 9.5

Post by skioakenfull » Mon Mar 14, 2016 10:40 pm

Hi jur

Thanks for the reply..
Yeah, I'm sure it must be my own filesystem slowing it down. I'll do some more testing ;)

Thanks
Ski

inkjt510
Posts: 23
Joined: Wed Aug 04, 2010 4:33 pm

Re: Browser search slow in 9.5

Post by inkjt510 » Mon Mar 14, 2016 11:14 pm

how long have you been using the new version for? is it possible that live is still indexing? (to check you can open activity monitor on a mac and look for the ableton index process)

skioakenfull
Posts: 5
Joined: Mon Mar 14, 2016 8:20 pm

Re: Browser search slow in 9.5

Post by skioakenfull » Mon Mar 14, 2016 11:32 pm

Hi
Thanks for the reply.
I've been using it for months, so it should be indexed by now.
Actually I'm wondering if there is a way to force a re-index - maybe it would help?
The problem only seems to be with the 'Sounds' category. All others (Drums etc) are instantaneous.

Thanks
Ski

warbird199
Posts: 6
Joined: Sun Jun 22, 2008 4:57 pm

Re: Browser search slow in 9.5

Post by warbird199 » Wed Apr 20, 2016 2:55 am

I am having the same issue when searching the "Sounds" category. It is very slow and I'm constantly getting a beachball.

Still not fixed in Live 9.6.1!

I've checked my activity monitor. Live is still running the index process. This issue has been occurring for months now.

skioakenfull
Posts: 5
Joined: Mon Mar 14, 2016 8:20 pm

Re: Browser search slow in 9.5

Post by skioakenfull » Wed Apr 20, 2016 7:44 am

A certified user colleague of mine has posted in the certified forum, and no one replied unfortunately so either not many people are experiencing this or just not bothered by it. I am however! I made a quick video showing what's happening..
https://www.youtube.com/watch?v=3T7E5a1 ... e=youtu.be

SCHALL
Posts: 3
Joined: Sun Sep 01, 2013 5:54 pm

Re: Browser search slow in 9.5

Post by SCHALL » Tue May 31, 2016 5:48 am

Hello,

I have the same problem here, only with the 'Sounds' category.

I have contacted the Ableton Support about it.
We've tried many things together as re-indexing, re-installing database, cleaning some caches .... nothing worked ... it's still slow.
I just processed a clean install on my mac ... still the same problem.

I was wondering if it was not connected with the size of my Ableton Library (which is often crashing when I scan it) ...

skioakenfull
Posts: 5
Joined: Mon Mar 14, 2016 8:20 pm

Re: Browser search slow in 9.5

Post by skioakenfull » Tue May 31, 2016 10:08 am

Hi Schall

Thanks for replying..
I'm interested to know if Ableton acknowledged this as a rare case, or if it's actually the same for everyone.
Even if your library is big, surely indexing should deal with it?

SCHALL
Posts: 3
Joined: Sun Sep 01, 2013 5:54 pm

Re: Browser search slow in 9.5

Post by SCHALL » Tue May 31, 2016 10:22 am

Hey skioakenfull,

The Ableton technician didn't mention if it was a rare case or not...
I should add the fact that this problem appeared after my upgrade to Live 9.5.

I sent Ableton a crash report and they first answered this :
It might not directly be the cause for this browser performance issue, but I identified a problem that we should solve first.
On your machine there seems to be a problem of increased memory load with Live 9.5, which is apparently caused by having "Complex" selected as Default Warp Mode. This causes a problem with Live 9.5 in combination with the warping feature of the new Simpler. Simpler erroneously creates a lot of warping related data, even when warping isn't enabled. The amount of created data might be so huge that it's causing an extremely increased memory allocation and thus severe performance issues.
--end

After that process, I reset the browser Database :
https://www.ableton.com/en/help/article ... malformed/
as nothing changed, I re installed live and the problem still persist...

I should try to install another version of Ableton on my laptop (another user maybe) and check if with default (small) library it's acting the same ...

Warweb
Posts: 2
Joined: Tue Sep 11, 2012 4:57 am

Re: Browser search slow in 9.5

Post by Warweb » Fri Feb 01, 2019 2:38 am

Reopening this as I am having the exact problem on Windows 10 with Live 10.0.6, I've opened a support ticket. Is this a known/solved bug or what?

EDIT: I was told the same thing, to reset the Live Database. Didn't work.

RyanDur
Posts: 1
Joined: Sat Mar 16, 2019 7:16 pm

Re: Browser search slow in 9.5

Post by RyanDur » Sat Mar 16, 2019 7:21 pm

Also dealing with an INDEX issue!! I've tried everything.. For me, the core library never shows up in Categories. Search doesn't work. For me, It's as if the indexer never runs. I see core library files in Places > Packs but they aren't organized under Categories (Sounds, Drums etc.) and can't be searched.

Post Reply