Anyone else getting this slow plugins loading on 12.0.10?

Discuss music production with Ableton Live.
Post Reply
Dosxxx
Posts: 2
Joined: Sun Jun 30, 2024 12:41 am

Anyone else getting this slow plugins loading on 12.0.10?

Post by Dosxxx » Sun Jun 30, 2024 12:51 am

I just updated to 12.0.10 on a mac (OS 12.7.1)
When I click my plugin folder it takes a while to load the plugin list, three loading dots run for about 5 seconds before the plugins are listed, anyone else getting this?

It's also become glitchy when dragging plugins to tracks when the session is playing now too.

Image

Edit: the image linking doesn't seem to work here, here's a screenshot https://ibb.co/GPkKKkW

Dosxxx
Posts: 2
Joined: Sun Jun 30, 2024 12:41 am

Re: Anyone else getting this slow plugins loading on 12.0.10?

Post by Dosxxx » Sat Jul 06, 2024 1:02 am

Bump.

Anyone know if 12.1 fixes this?

S4racen
Posts: 5868
Joined: Fri Aug 24, 2007 4:08 pm
Location: Dunstable
Contact:

Re: Anyone else getting this slow plugins loading on 12.0.10?

Post by S4racen » Sat Jul 06, 2024 1:53 pm

Doesn't look like anyone else is having the same issue...
Cheers
D

x3000
Posts: 17
Joined: Wed Oct 04, 2023 2:47 pm

Re: Anyone else getting this slow plugins loading on 12.0.10?

Post by x3000 » Wed Jul 10, 2024 8:23 am

No, I don't have the problem, but I would say it's 100% due to a third party plugin.
So temporarily move all plugins out of the VST plugin folder (third party) and add them back one by one, restart Live each time or re-scan the plugin folder in the settings and see if it has disappeared. If the problem reappears with a plug-in, you have the culprit.

JasonW
Posts: 20
Joined: Sat Jul 08, 2023 10:53 am

Re: Anyone else getting this slow plugins loading on 12.0.10?

Post by JasonW » Wed Jul 10, 2024 10:53 am

Agree with x3000. Another (potentially faster) sorting strategy for finding the culprit is to work in the other direction.

Meaning take away (move to the temp folder) half of the plugins, and see if that solves it. If so, then you know the culprit is in that half. If not, swap the two halves by moving the temps back to active and the actives to the temp. Then see if it's in that other half. If removing one of those groups solves the problem, keep the "offending" group in play and move the "safe" group to a temp subfolder.

Then divide the offending group in half and repeat the process. Just keep repeating with progressively smaller groups until you find the plugin causing the problem. The advantage with this approach is that you might find out quickly that it's not a plugin causing the issue. If for instance, during the first couple of steps, neither group of plugins seems to be responsible for the issue.

Hope that is helpful. Good luck! When you find a solution, please let us know!

cotdagoo
Posts: 1058
Joined: Fri Oct 26, 2007 5:34 pm
Location: canuhduh

Re: Anyone else getting this slow plugins loading on 12.0.10?

Post by cotdagoo » Thu Jul 11, 2024 8:10 pm

The issue has been reported in Centercode/beta testing. It is related to the "Group by Creator" function that's enabled by default in Live 12.0.5 and beyond.

If you disable Group by Creator, all the plugins display quickly without delay, it's just a long list - especially if you have VST2 and VST3 plugins side by side.

I have a 10 second delay anytime I access my Plug-Ins panel with Group by Creator enabled.

Post Reply