Fix for envelope 'auto fit to height'

Share your wishes for the future of Ableton Live
Poster
Posts: 8804
Joined: Sat Mar 05, 2005 2:21 am
Location: Amsterdam

Fix for envelope 'auto fit to height'

Post by Poster » Fri Sep 15, 2006 2:57 pm

This not even a feature wish,
this is a request for a feature fix..
This is there since L4 and also issued while beta testing L5 and L6.. and L7..

in Arrange and Session: envelopes with a dividing vertical grid do not 'auto fit to height' on resize and on initial height..


On the left side you see an envelope lane that doesn't have a vertical devided grid
and does always autofit to 100%, no matter what size you drag the lane..

On the right side you see an envelope lane that does have a vertical devided grid
and doesn't autofit to 100%, no matter what size you drag the lane.

So; if I want to draw an envelope I can't see the min/max value of this parameter so I have to scroll up/down..

IMO this is not wanted behaviour cause it makes it almost impossible to do accurate editing.. There is no overview at all..
In this example there are only 3 tracks, but imagine having 13 tracks; not done..

This behaviour is with all parameters on all devices that have a vertical devider for the grid, in arrange and session..

(the pink overlay is the envelope lane's height [100%])

Image
Last edited by Poster on Tue Mar 04, 2008 10:58 pm, edited 1 time in total.

Meef Chaloin
Posts: 2164
Joined: Thu Jul 21, 2005 10:09 pm

Post by Meef Chaloin » Fri Sep 15, 2006 3:10 pm

yeah i find this very annoying

Poster
Posts: 8804
Joined: Sat Mar 05, 2005 2:21 am
Location: Amsterdam

Post by Poster » Fri Sep 15, 2006 3:24 pm

Why do they drag this behaviour all the way, even into L6?
This really bugs me bigtime..
How on earth can we do proper editing like this?

My guess is that with the introduction of L4 there wasn't a proper solution for this problem and it landed on the bottom of the improvement list..

This has to be fixed pronto if you ask me,
because this improvement shouldn't be on the list at all..

Poster
Posts: 8804
Joined: Sat Mar 05, 2005 2:21 am
Location: Amsterdam

Post by Poster » Sat Dec 02, 2006 1:49 am

I really like this to be on top of the improvement list..
today was a hard day editing :cry:

Poster
Posts: 8804
Joined: Sat Mar 05, 2005 2:21 am
Location: Amsterdam

Post by Poster » Tue Oct 09, 2007 2:05 pm

how long is this ugly thing going to be dragged along?

sorry, but I'm really pissed off today..
how on earth can we do proper envelope editing like this?

multi envelope lanes; nice!
but sadly only a half feature because of this..

this is not a bug, its a design flaw..


[/rant]

peeddrroo
Posts: 4767
Joined: Fri Mar 26, 2004 10:25 pm
Location: France

Post by peeddrroo » Tue Oct 09, 2007 2:37 pm

+1

and i also despise the fact that when you're scrolling and the mouse gets over this area, suddenly it's the automation that starts scrolling.

peeddrroo
Posts: 4767
Joined: Fri Mar 26, 2004 10:25 pm
Location: France

Post by peeddrroo » Tue Oct 09, 2007 2:38 pm

geee i thought we were in the beta testing forum.

did you make a bug report marco?

Poster
Posts: 8804
Joined: Sat Mar 05, 2005 2:21 am
Location: Amsterdam

Post by Poster » Tue Oct 09, 2007 2:43 pm

peeddrroo wrote: did you make a bug report marco?
yep, two years ago, at 5 beta testing.. :(

Poster
Posts: 8804
Joined: Sat Mar 05, 2005 2:21 am
Location: Amsterdam

Post by Poster » Thu Feb 07, 2008 8:43 pm

............................. ?

tylast
Posts: 650
Joined: Thu Jun 19, 2003 10:58 pm
Location: AZ, US
Contact:

Post by tylast » Fri Feb 08, 2008 12:32 am

+1
Live 7.0.14 / Vista SP1 / Intel QX6700 / 4GB DDR2 / ReMOTE 25SL Compact

Image

Poster
Posts: 8804
Joined: Sat Mar 05, 2005 2:21 am
Location: Amsterdam

Post by Poster » Tue Mar 04, 2008 10:34 pm

:arrow: :idea: :arrow: :idea: :arrow: :idea:

tylast
Posts: 650
Joined: Thu Jun 19, 2003 10:58 pm
Location: AZ, US
Contact:

Post by tylast » Mon Mar 31, 2008 11:20 am

Not forgotten. 8)
Live 7.0.14 / Vista SP1 / Intel QX6700 / 4GB DDR2 / ReMOTE 25SL Compact

Image

djgroovy
Posts: 2025
Joined: Thu Sep 28, 2006 12:15 pm
Location: Portugal

Post by djgroovy » Mon Mar 31, 2008 3:46 pm

+1

Poster
Posts: 8804
Joined: Sat Mar 05, 2005 2:21 am
Location: Amsterdam

Post by Poster » Wed Apr 16, 2008 9:00 pm

I don't mean to rub it in but this is such an ugly design flaw..

Poster
Posts: 8804
Joined: Sat Mar 05, 2005 2:21 am
Location: Amsterdam

Post by Poster » Wed Dec 10, 2008 12:22 am

bump..

Post Reply