Push developer kit: M4L devices for Push!

Come here to discuss Push with other users.
For tech support, please head to http://www.ableton.com/help
flocked
Posts: 45
Joined: Wed Aug 18, 2010 2:42 pm

Re: Push developer kit: M4L devices for Push!

Post by flocked » Sat Apr 06, 2013 3:25 am

What is your Push grid showing? the standard note grid? or no led colors.

Make sure your Push is turned on, before adding the m4l device.

"Push control, when" does exactly, what it says. If you select the m4l device or the track, containing the m4l device (depending on your selected option) the custom grid should show.

Dchild
Posts: 77
Joined: Thu Dec 27, 2007 9:14 pm
Location: Sydney

Re: Push developer kit: M4L devices for Push!

Post by Dchild » Sat Apr 06, 2013 4:47 am

its Just showing the standard grid. The track is selected.

Bumper :(

flocked
Posts: 45
Joined: Wed Aug 18, 2010 2:42 pm

Re: Push developer kit: M4L devices for Push!

Post by flocked » Sat Apr 06, 2013 7:09 pm

Okay, could you please try out these two m4l devices?
http://florianzand.de/push/m4l_devices/tests.zip

Test 1: What happens with the Push grid, if you activate the toggle?
Test 2: What happens with the Push grid, if you add the m4l device to your track? What is the message box showing?

Thanks!

guillaume82
Posts: 13
Joined: Sat Mar 09, 2013 3:36 pm

Re: Push developer kit: M4L devices for Push!

Post by guillaume82 » Sun Apr 07, 2013 10:14 am

Hi flocked - thanks for the work on this!

The polygome device works fine on Live 9.0.2, however it doesn't (showing just the normal grid as Dchild describes) in the latest beta (9.0.3 b3)

Here are the results for the tests under 9.0.3b3 (and between brackets the result under 9.0.2)

Test 1: top left pad flashes, maybe red but happening very fast so not 100% sure, then stays lit in dark red. If you deactivate the toggle the top left pad stays dark red (9.0.2: grid disappears to leave a blank grid, reappears when the toggle is deactivated )

Test 2: nothing happens to the grid, Push message box shows under the left knob PshCntrl DvcSlctd (9.0.2: grid disappears as in test 1, message box shows same as in the beta, grid reappears if I turn the knob to PshCntrl Off and disappears again if I switch to track or device select mode)

So it sounds like it's a beta issue...

Thanks !

Siege
Posts: 6
Joined: Wed Nov 04, 2009 6:53 pm

Re: Push developer kit: M4L devices for Push!

Post by Siege » Sun Apr 07, 2013 1:40 pm

Good work!

Regarding the closebang issue, try freebang, I had better results with this object in M4L.

flocked
Posts: 45
Joined: Wed Aug 18, 2010 2:42 pm

Re: Push developer kit: M4L devices for Push!

Post by flocked » Sun Apr 07, 2013 8:01 pm

Thanks for your help.

Yes, it seems, that 9.0.3 breaks the "call grab_control" message. I contacted Ableton about it.

@Siege: Freebang isn't working either. The both send a bang, but just to late.

coleb
Posts: 40
Joined: Tue Apr 02, 2013 3:16 am

Re: Push developer kit: M4L devices for Push!

Post by coleb » Sun Apr 07, 2013 11:51 pm

hi flocked - when using the push_grid device to grab the pads to generate midi notes when pressed, i seem to be getting a slight bit of latency that is not present when using push in native live mode to play the same instruments. is this just an inherent limitation to using M4L? or is there something I am missing? thanks!

yop44
Posts: 182
Joined: Wed Nov 11, 2009 3:02 pm

Re: Push developer kit: M4L devices for Push!

Post by yop44 » Mon Apr 08, 2013 8:16 am

Thanks Flocked for this awesome work!

I have a question. Is there a way to release control before deleting a device. Because one a device using push_grid deleted the is no way ti use pads again.

regards
My music : Soundcloud

lo.key
Posts: 360
Joined: Tue Dec 22, 2009 7:05 pm

Re: Push developer kit: M4L devices for Push!

Post by lo.key » Mon Apr 08, 2013 4:18 pm

@yop44, you'll need to add another patch to reclaim control if you delete the original patch without releasing control.

yop44
Posts: 182
Joined: Wed Nov 11, 2009 3:02 pm

Re: Push developer kit: M4L devices for Push!

Post by yop44 » Mon Apr 08, 2013 4:29 pm

lo.key wrote:@yop44, you'll need to add another patch to reclaim control if you delete the original patch without releasing control.
Thanks, but I'm not sure that's a handy solution...
My music : Soundcloud

anamexis
Posts: 582
Joined: Sat Dec 18, 2004 9:43 pm
Location: Oakland
Contact:

Re: Push developer kit: M4L devices for Push!

Post by anamexis » Mon Apr 08, 2013 5:11 pm

yop44 wrote:Thanks Flocked for this awesome work!

I have a question. Is there a way to release control before deleting a device. Because one a device using push_grid deleted the is no way ti use pads again.

regards
As is noted on the site and in the readme, this is a bug with Max For Live and closebang.

lo.key
Posts: 360
Joined: Tue Dec 22, 2009 7:05 pm

Re: Push developer kit: M4L devices for Push!

Post by lo.key » Mon Apr 08, 2013 9:47 pm

yop44 wrote:
lo.key wrote:@yop44, you'll need to add another patch to reclaim control if you delete the original patch without releasing control.
Thanks, but I'm not sure that's a handy solution...

agreed. the 'handy' solution is not to delete the patch in the first place, as the docs spell out.

flocked
Posts: 45
Joined: Wed Aug 18, 2010 2:42 pm

Re: Push developer kit: M4L devices for Push!

Post by flocked » Tue Apr 09, 2013 7:55 am

Yes, as stated in the bug list, it is definitely a bug and shouldn't be the default behavior. It would be stupid to require the user all the time to remember deactivating the device before deleting.
Maybe some m4l developers can find a solution. - If you connect closebang with the "release_control" message in a push control object, nothing happens, because the bang never receives/triggers the message. Is there another way/walk around? Maybe some way to slower the deletion?

coleb: Are you sure that you get a lag? Is it only if you have the max editor open (which makes all push objects much slower) or general?

yop44: Currently you need to deactivate the device or the push control in option menu.

monohusche
Posts: 190
Joined: Thu Jan 22, 2009 4:28 pm
Location: Hongkong

Re: Push developer kit: M4L devices for Push!

Post by monohusche » Tue Apr 09, 2013 8:22 am

flocked wrote:Yes, as stated in the bug list, it is definitely a bug and shouldn't be the default behavior. It would be stupid to require the user all the time to remember deactivating the device before deleting.
Maybe some m4l developers can find a solution. - If you connect closebang with the "release_control" message in a push control object, nothing happens, because the bang never receives/triggers the message. Is there another way/walk around? Maybe some way to slower the deletion?

coleb: Are you sure that you get a lag? Is it only if you have the max editor open (which makes all push objects much slower) or general?

yop44: Currently you need to deactivate the device or the push control in option menu.
have you played around with deferlow ? this deals with message prioritisation and helps quite often.

flocked
Posts: 45
Joined: Wed Aug 18, 2010 2:42 pm

Re: Push developer kit: M4L devices for Push!

Post by flocked » Tue Apr 09, 2013 1:31 pm

Deferlow isn't working. Why should it work? It makes sending the "release_control" message slower.
But thanks for your input :)

Post Reply