Ableton 10.0.2 performance loss.

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
konovalovua
Posts: 12
Joined: Tue May 29, 2018 12:02 pm

Ableton 10.0.2 performance loss.

Post by konovalovua » Tue May 29, 2018 12:20 pm

Well, yesterday i have updated from 10.0.1, and it become more laggy than it was.
My spec:
i7 6700
16gb RAM
asus z170-a
gtx 1050

Live installed on ssd, and im using AudioBox 22vsl.

Did anyone else noticed that GUI starts lagg more that it was on 10.0.1 ?
Playback line is blinking, and it feels like im trying to play a videogame, but my videocard cant give me enough FPS.

I perform clean install, so it was not an update.
I have no idea whats going on, but when i open FL Studio 20 - everything super smooth and without any glitches.

Let me know guys, if there any tips to fix this problem, and sorry for my english, im from Ukraine, and sometimes im dumb when trying to say what i want.

Best,
S

Muze
Posts: 168
Joined: Fri Jul 16, 2010 6:01 am

Re: Ableton 10.0.2 performance loss.

Post by Muze » Tue May 29, 2018 5:34 pm

The library is what seems to slow everything down for me. I click on a section and it takes a few seconds to a few minutes for anything to actually appear, then if I click on another section I get the same, it only seems to retain one section at a time. The places/packs section is fine and opens instantly, it's just this constant need it has to scan in the background, I would rather just have a normal drive location based browser like the places section than this useless library.

Angstrom
Posts: 14662
Joined: Mon Oct 04, 2004 2:22 pm
Contact:

Re: Ableton 10.0.2 performance loss.

Post by Angstrom » Tue May 29, 2018 6:26 pm

Muze wrote:The library is what seems to slow everything down for me. I click on a section and it takes a few seconds to a few minutes for anything to actually appear, then if I click on another section I get the same, it only seems to retain one section at a time. The places/packs section is fine and opens instantly, it's just this constant need it has to scan in the background, I would rather just have a normal drive location based browser like the places section than this useless library.
make sure you haven't added any huuuuge locations to Places. If you add your entire computer to places then the library constantly scans your entire computer, every single file.
My places are: Audio, Music, Live Songs. which probably covers half a terabyte or so. But if I allowed places to index my whole machine it would be about 8 terabytes.

Muze
Posts: 168
Joined: Fri Jul 16, 2010 6:01 am

Re: Ableton 10.0.2 performance loss.

Post by Muze » Tue May 29, 2018 8:04 pm

It isn't, just sample drives and presets. But it shouldn't need to keep scanning all the time, only when I add something new. Besides the slow bit is the library tab not the places tab.

Angstrom
Posts: 14662
Joined: Mon Oct 04, 2004 2:22 pm
Contact:

Re: Ableton 10.0.2 performance loss.

Post by Angstrom » Tue May 29, 2018 9:30 pm

Muze wrote:Besides the slow bit is the library tab not the places tab.
The library part scans and indexes the locations added in places

It seems you have deeper issues though.

jestermgee
Posts: 3323
Joined: Mon Apr 26, 2010 6:38 am
Contact:

Re: Ableton 10.0.2 performance loss.

Post by jestermgee » Tue May 29, 2018 11:03 pm

Haven't yet noticed any issues... In fact mine auto-updated to 10.0.2 and I didnt even notice at all for a day.

As mentioned (and a good point about the differences in how people set up their systems) if you have too much linked in with Live it will slow it down, especially if you have root folders that have all your other files on them. So that means trying to keep paths for your library to a minimum. If you have so much content that you need several drives with dozens of links into Live, you probably have more than you need really.

In regards to Live scanning for files, i'm no expert but after the files have all been scanned in then I believe the Indexer will be listening to each folder path for any changes then do a scan. If you have a system drive or a temp folder that has changes constantly going on then this will create issues with the indexer.

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Ableton 10.0.2 performance loss.

Post by Stromkraft » Wed May 30, 2018 7:34 am

Scans schmans. Get an SSD and keep it 20% free. If you already got one, then you have real issues as 10.0.2 is not slow at all, nor was 10.0.1.

I didn't add a complete disk, but I can tell you that I have tens of thousands of files indexed in my browser. I never ever notice the indexer.
Last edited by Stromkraft on Sat Jun 02, 2018 9:33 pm, edited 1 time in total.
Make some music!

konovalovua
Posts: 12
Joined: Tue May 29, 2018 12:02 pm

Re: Ableton 10.0.2 performance loss.

Post by konovalovua » Wed May 30, 2018 9:05 am

Same for me.
I have 140gb free space on SSD, and i keep my projects and all Ableton files on SSD.
The problem is in GUI performance, as i said in theme - feels like Ableton make 15fps, maybe i have to record a video.
There is no problems in audio, or files, just in performance at all.

kpv
Posts: 17
Joined: Sun May 20, 2018 10:51 am

Re: Ableton 10.0.2 performance loss.

Post by kpv » Wed May 30, 2018 1:05 pm

Sorry for hijacking the thread, but instead of making a new one with the excact same name... has anybody else noticed that 10.0.2 seems to be heavier on the CPU than 10.0.1 on Windows 10 (1803)? Shouldn't it be the other way around, each release being smoother on the performance side? I've yet to run into GUI problems myself but a semi-heavy project (Echo, 2x wavetable synths, some FX couple of tracks) that didn't crackle on 64 buffer setting in 10.0.1 does so in 10.0.2 while recording (so I need to freeze those Wavetable tracks before recording).

The projects have not been changed a bit since I updated, neither has my system or the drivers, so I'm guessing 10.0.2 seems to consume more CPU resources than 10.0.1.

konovalovua
Posts: 12
Joined: Tue May 29, 2018 12:02 pm

Re: Ableton 10.0.2 performance loss.

Post by konovalovua » Wed May 30, 2018 11:09 pm

kpv wrote:Sorry for hijacking the thread, but instead of making a new one with the excact same name... has anybody else noticed that 10.0.2 seems to be heavier on the CPU than 10.0.1 on Windows 10 (1803)? Shouldn't it be the other way around, each release being smoother on the performance side? I've yet to run into GUI problems myself but a semi-heavy project (Echo, 2x wavetable synths, some FX couple of tracks) that didn't crackle on 64 buffer setting in 10.0.1 does so in 10.0.2 while recording (so I need to freeze those Wavetable tracks before recording).

The projects have not been changed a bit since I updated, neither has my system or the drivers, so I'm guessing 10.0.2 seems to consume more CPU resources than 10.0.1.
Im pretty sure i have same issue (i also updated to 1803), but GUI laggs was before i've updated Windows to 1803, so i think its not a Windows problem.
Sad, but 99% its an Ableton problem, and they literally cant make their soft smooth in 2018.
Im not an developer or something like this, but im sure its not super big problem for a company like Ableton, maybe im wrong, but when i opened FL Studio 12 for first time, i was shocked, it was so smooth and nice, i was like "wtf is going on".
Hope Ableton will fix 10.0.2 ASAP.

solar28
Posts: 60
Joined: Mon Jul 25, 2005 7:43 am
Contact:

Re: Ableton 10.0.2 performance loss.

Post by solar28 » Thu May 31, 2018 4:27 am

Definitely a problem with the new update. 10.0.0.1 was snappy for me with no GUI lag. Literally used it while waiting for update to download. Upon launch, intermittent stuck GUI. Knobs/sliders etc don't respond for up to 10 seconds (even though the sound will change). CPU use at about 10%.

Killed Ableton index process through task manager. No change. Trashed prefs, which resets ableton to default. No change. Definitely has nothing to do with browser. GUI is intermittently freezing in the background as I type this.

[jur]
Site Admin
Posts: 1687
Joined: Mon Jun 01, 2015 3:04 pm
Location: Ableton

Re: Ableton 10.0.2 performance loss.

Post by [jur] » Thu May 31, 2018 5:53 am

There are some Windows fixes, partly related to hidpi/hi-res screen stuff. Maybe you're experiencing something related that hasn't been noticed before. So please report to support@ableton.com and they'll help you.
Ableton Forum Moderator

Reemo
Posts: 16
Joined: Tue Mar 13, 2018 6:52 pm

Re: Ableton 10.0.2 performance loss.

Post by Reemo » Thu May 31, 2018 7:17 am

Holy crap. Just had that GUI freeze people describe in 10.0.2. I just closed VST window. I was able to control ableton with midi, window close button also works fine.

konovalovua
Posts: 12
Joined: Tue May 29, 2018 12:02 pm

Re: Ableton 10.0.2 performance loss.

Post by konovalovua » Thu May 31, 2018 10:25 am

[jur] wrote:There are some Windows fixes, partly related to hidpi/hi-res screen stuff. Maybe you're experiencing something related that hasn't been noticed before. So please report to support@ableton.com and they'll help you.
No, its not a Windows problem.
I was on Windows 1709 when installed 10.0.2 (100% clear install from 0), there was an GUI laggs and performance loss, after i have updated to 1803 - same issues, no changes.

slashsound
Posts: 5
Joined: Thu Feb 08, 2018 12:06 am

Re: Ableton 10.0.2 performance loss.

Post by slashsound » Thu May 31, 2018 12:45 pm

I am running windows 10 and Ableton 10.0.2 is running really laggy

Post Reply